summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-07-11 01:38:47 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-07-11 01:38:47 +0000
commit8caebc0505d019620cd3e8fec6ca66b9e02c41cb (patch)
tree2a50ef66378d3aad438414714d527b69e9509d1c /configure.ac
parentd575c7ebfbeb93bb9fa57e4aff99f85ed4abab5e (diff)
downloadmpfr-8caebc0505d019620cd3e8fec6ca66b9e02c41cb.tar.gz
[configure.ac] Moved AM_PROG_AR (introduced in r8546) after the
CC and CFLAGS setup from gmp.h, because AM_PROG_AR makes Autoconf select a compiler (before it may be chosen from __GMP_CC). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8611 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c69d83f2f..35af7c87f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,14 +46,14 @@ if test -n "$CFLAGS" || test -n "$CC" ; then
user_redefine_cc=yes
fi
+dnl Basic Autoconf macros. At this point, they must not make Autoconf
+dnl choose a compiler because of the CC and CFLAGS setup from gmp.h!
+
AC_CANONICAL_HOST
AC_PROG_EGREP
AC_PROG_SED
-dnl Support unusual archivers.
-AM_PROG_AR
-
dnl To use a separate config header.
dnl There is still some problem with GMP's HAVE_CONFIG
dnl AC_CONFIG_HEADERS([mpfrconf.h:mpfrconf.in])
@@ -179,6 +179,10 @@ dnl
dnl ********************************************************************
dnl Check for CC and CFLAGS in gmp.h
+dnl Warning! The following tests must be done before Autoconf selects
+dnl a compiler. This means that some macros such as AC_PROG_CC and
+dnl AM_PROG_AR must be put after the following code.
+
if test -z "$user_redefine_cc" && test "$cross_compiling" != yes ; then
dnl We need to guess the C preprocessor instead of using AC_PROG_CPP,
@@ -243,6 +247,9 @@ AC_PROG_CC
AC_PROG_CPP
AC_LANG(C)
+dnl Support unusual archivers.
+AM_PROG_AR
+
dnl For GCC, _Decimal64 was introduced in GCC 4.3 for some targets
dnl (note that it is not guaranteed to be available because it may
dnl be disabled in the GCC build). See: