summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2016-05-24 10:47:12 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2016-05-24 10:47:12 +0000
commiteea968e9b61e29e207d4e8e813da86ef1b77d511 (patch)
tree4fcd8072a953dea8ebaca00506ba25eab217d694 /configure.ac
parent326335142e88b698bb34e3662c0b159d68f892da (diff)
downloadmpfr-eea968e9b61e29e207d4e8e813da86ef1b77d511.tar.gz
Added optional LTO support (from a patch by Patrick PĂ©lissier).
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@10345 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c8458f0f..3205df555 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,6 +293,7 @@ AC_LANG(C)
dnl Support unusual archivers.
AM_PROG_AR
+AC_PROG_RANLIB
dnl Try to determine the double format
AC_MSG_CHECKING(format of `double' floating point)
@@ -391,6 +392,18 @@ AC_ARG_ENABLE(debug-prediction,
*) AC_MSG_ERROR([bad value for --enable-debug-prediction: yes or no]) ;;
esac])
+AC_ARG_ENABLE(lto,
+ [ --enable-lto build MPFR with link-time-optimization
+ (experimental) [[default: no]]],
+ [ case $enableval in
+ yes) if test "$enable_shared" != "no"; then
+ AC_MSG_ERROR([--enable-lto can only work in static mode (--disable-shared)])
+ fi
+ enable_lto=yes
+ ;;
+ no) ;;
+ *) AC_MSG_ERROR([bad value for --enable-lto: yes or no]) ;;
+ esac])
dnl Check if compiler is ICC, and if such a case, disable GCC
dnl And add some specific flags.