summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2006-07-18 07:51:58 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2006-07-18 07:51:58 +0000
commit2f528ae079a35af19a4a334d7e0ef9929079a9f3 (patch)
tree82dace9e2c7c83a3b40a2a86a6d17acc90229991 /configure.in
parentf77b517b8c34312fabab8ee854d811503f4f58f8 (diff)
downloadmpfr-2f528ae079a35af19a4a334d7e0ef9929079a9f3.tar.gz
configure.in: fixed a linking problem on darwin.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@4103 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 22102146a..ef99a2273 100644
--- a/configure.in
+++ b/configure.in
@@ -176,6 +176,21 @@ case $OS_TYPE in
;;
esac
+dnl $OS_TYPE is not defined on darwin, so we use $host
+case $host in
+ *-apple-darwin*)
+dnl This allows to take the first GMP library in the library paths,
+dnl whether it is dynamic or static. This behavior is more sensible,
+dnl in particular because it is the only way to link with a version
+dnl only available in static form when another version is available
+dnl in dynamic, and also for consistency, because the compiler will
+dnl take the first gmp.h found in the include paths (so, we need to
+dnl take a library that corresponds to this header file). This is a
+dnl common problem with darwin.
+ LDFLAGS="-Wl,-search_paths_first $LDFLAGS"
+ ;;
+esac
+
AC_C_CONST
AC_C_VOLATILE
MPFR_CONFIGS