summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2006-05-19 16:43:35 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2006-05-19 16:43:35 +0000
commit37a41e6ff7b3297bc2cb7fec32f75c4a048145f9 (patch)
treef21bfb6413092dc963478dbf6df77a58eaf4a418 /configure.in
parent1df310a144bb39eb34594f5be80551fa2e4c4f0b (diff)
downloadmpfr-37a41e6ff7b3297bc2cb7fec32f75c4a048145f9.tar.gz
Add compiler flags (CPPFLAGS, LDFLAGS) in a consistent order.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@4081 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d08420574..c8b054b6b 100644
--- a/configure.in
+++ b/configure.in
@@ -39,11 +39,11 @@ AC_ARG_WITH(gmp_include,
CPPFLAGS="$CPPFLAGS -I$withval")
AC_ARG_WITH(gmp_lib,
[ --with-gmp-lib=DIR GMP lib directory ],
- LDFLAGS="-L$withval $LDFLAGS")
+ LDFLAGS="$LDFLAGS -L$withval")
AC_ARG_WITH(gmp_build,
[ --with-gmp-build=DIR GMP build directory], [
CPPFLAGS="$CPPFLAGS -I$withval -I$withval/tune"
- LDFLAGS="-L$withval -L$withval/.libs -L$withval/tune/ $LDFLAGS"
+ LDFLAGS="$LDFLAGS -L$withval -L$withval/.libs -L$withval/tune/"
if test -r $withval/Makefile ; then
GMP_CFLAGS=`grep -w "CFLAGS =" $withval/Makefile | sed 's/CFLAGS = //'`
GMP_CC=`grep -w "CC =" $withval/Makefile | sed 's/CC = //'`
@@ -52,7 +52,7 @@ AC_ARG_WITH(gmp_build,
AC_ARG_WITH(gmp,
[ --with-gmp=DIR GMP install directory ], [
CPPFLAGS="$CPPFLAGS -I$withval/include"
- LDFLAGS="-L$withval/lib $LDFLAGS" ])
+ LDFLAGS="$LDFLAGS -L$withval/lib" ])
AC_ARG_WITH(irix64,
[ --with-irix64=on/off Irix 32/64 bits support ],
@@ -164,7 +164,7 @@ dnl Set the OS-dependent flags.
case $OS_TYPE in
HP-UX*)
if test -n "$GCC"; then
- LDFLAGS="-Xlinker +allowunsats $LDFLAGS"
+ LDFLAGS="$LDFLAGS -Xlinker +allowunsats"
fi
;;
IRIX64)