summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpelissip <pelissip@280ebfd0-de03-0410-8827-d642c229c3f4>2005-05-03 09:51:50 +0000
committerpelissip <pelissip@280ebfd0-de03-0410-8827-d642c229c3f4>2005-05-03 09:51:50 +0000
commitbe1630fdd302a6f157e361dbf2130901ebcf4f7b (patch)
treedff30d8ecaebbe375df7379533c07161fbbd096b /configure.in
parent4d78b53743bf41a50a6b4c53b3050f9bf7cbfe96 (diff)
downloadmpfr-be1630fdd302a6f157e361dbf2130901ebcf4f7b.tar.gz
Add detection of function round, rint, ceil, floor and nearbyint at configure
time so that spe206 which defines itself as C99 compliant can build the trint test. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@3517 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0a4701180..6d16428d6 100644
--- a/configure.in
+++ b/configure.in
@@ -175,6 +175,12 @@ AC_C_CONST
AC_C_VOLATILE
MPFR_CONFIGS
+dnl Must be checked with the LIBM
+dnl but we don't to add the LIBM to MPFR dependency.
+saved_LIBS="$LIBS"
+LIBS="$LIBS $MPFR_LIBM"
+AC_CHECK_FUNCS([round trunc floor ceil nearbyint])
+LIBS="$saved_LIBS"
dnl
dnl Setup LIBTOOL
@@ -318,7 +324,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[
)
dnl Remove also many MACROS (AC_DEFINE) which are unused by MPFR
-dnl and polluate the build.
+dnl and polluate (and slow down) the build.
if test -f confdefs.h; then
sed '/#define PACKAGE_/d' <confdefs.h >confdefs.tmp
sed '/#define HAVE_STRING/d' <confdefs.tmp >confdefs.h