summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2007-05-28 13:56:33 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2007-05-28 13:56:33 +0000
commitf3d829b3fe191e22992a724e88ce2364e1c24828 (patch)
tree881fe476c08c69b86ee0bbb7f1a8a26729b382ca /configure.in
parent0513b44095acb0e516ace867b9603eee9956f3d0 (diff)
downloadmpfr-f3d829b3fe191e22992a724e88ce2364e1c24828.tar.gz
Changed --with-tests-timeout into --enable-tests-timeout as documented
in the autoconf manual (--with-* are for external packages only). When this is enabled, environment variable MPFR_TESTS_TIMEOUT allows to override the default timeout (use the value 0 to disable timeouts). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@4477 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 41a145103..b19275d49 100644
--- a/configure.in
+++ b/configure.in
@@ -146,9 +146,17 @@ return y.d == 0.14894469406741037E-123 ? 0 :
*) AC_MSG_ERROR([bad value for --enable-decimal-float: yes or no]) ;;
esac])
-AC_ARG_WITH(tests-timeout,
- [ --with-tests-timeout=NUM limit in seconds for test programs],
- AC_DEFINE_UNQUOTED([MPFR_TEST_TIMEOUT],$withval, [timeout limit]))
+AC_ARG_ENABLE(tests-timeout,
+ [ --enable-tests-timeout=NUM enable timeout (NUM seconds) for test programs
+ (NUM <= 9999) [[default=no]]; if enabled, env variable
+ $MPFR_TESTS_TIMEOUT overrides NUM (0: no timeout).],
+ [ case $enableval in
+ no) ;;
+ yes) AC_DEFINE([MPFR_TESTS_TIMEOUT], 0, [timeout limit]) ;;
+ [[0-9]]|[[0-9]][[0-9]]|[[0-9]][[0-9]][[0-9]]|[[0-9]][[0-9]][[0-9]][[0-9]])
+ AC_DEFINE_UNQUOTED([MPFR_TESTS_TIMEOUT], $enableval, [timeout limit]) ;;
+ *) AC_MSG_ERROR([bad value for --enable-tests-timeout]) ;;
+ esac])
dnl