summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpelissip <pelissip@280ebfd0-de03-0410-8827-d642c229c3f4>2005-02-11 13:08:25 +0000
committerpelissip <pelissip@280ebfd0-de03-0410-8827-d642c229c3f4>2005-02-11 13:08:25 +0000
commit0091ec3624248972552727149845267d7013a3de (patch)
tree3eee1be8e45ee139c6bc8fc5aabe53a0effda568 /configure.in
parent792230ac910a791f667aa313e0c1c3370b651939 (diff)
downloadmpfr-0091ec3624248972552727149845267d7013a3de.tar.gz
Remove detection of C++ and Fortran due to libtool.
---- Note (VL, 2010-02-08): this removal by an always false test was working with libtool 1.5.26, but doesn't work with libtool 2.2 to 2.2.6b (used by the MPFR 2.4.{0,1,2} tarballs). http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=568520 git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@3293 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 25e4e06a8..9adf10743 100644
--- a/configure.in
+++ b/configure.in
@@ -176,16 +176,20 @@ MPFR_CONFIGS
dnl
dnl Setup LIBTOOL
dnl
-dnl Currently libtool always detect a C++ and fortran compiler
-dnl Reduce the search list to g++ and g77
-dnl It may freeze with cl on some systems with old libtool.
-dnl For CXXCPP, it is definitevely an ugly hack which should be remove
-dnl as soon as possible but otherwise some systems may not be able to
-dnl build MPFR while they should.
+dnl Currently libtool always want to detect a C++ and fortran compiler
+dnl Remove this by hacking a few: AC_PROG_CXX, AC_PROG_F77 are defined
+dnl but they are never called. Set with_tag to ''
+dnl Set am__fastdepCXX to something
dnl Remove this when Libtool >= 2.0 is used
-AC_PROG_CXX([g++])
-AC_PROG_F77([g77])
-dnl CXXCPP="grep limits"
+if test -n "$variable_indefinie" ; then
+ AC_PROG_CXX([g++])
+ AC_PROG_F77([g77])
+ AC_PROG_CXXCPP
+fi
+am__fastdepCXX_FALSE='#'
+if test "${with_tags+set}" != set; then
+ with_tags=
+fi
dnl Configs for Windows DLLs.
dnl libtool requires "-no-undefined" for win32 dll
@@ -217,9 +221,6 @@ case $host in
;;
esac
# Never enable CXX and GCJ in libtool (remove this for libtool >= 2.0)
-if test "${with_tags+set}" != set; then
- with_tags=
-fi
dnl Finally set up LibTool
AC_PROG_LIBTOOL