summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2005-08-31 12:18:31 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2005-08-31 12:18:31 +0000
commit22d0ee7fb7e6b3814711d94591167ec1f77acd01 (patch)
tree59b86dc5845238cf95bdbd4b7546a591182e67b9 /configure.in
parente77f777fb9dfae3e3038c57e2bc15296173a8994 (diff)
downloadmpfr-22d0ee7fb7e6b3814711d94591167ec1f77acd01.tar.gz
Fix for the following problem: #error is not sufficient with cc
on IRIX64, and autoconf 2.59 doesn't cope with that. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@3749 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 42c730e78..0344bbbe0 100644
--- a/configure.in
+++ b/configure.in
@@ -127,6 +127,7 @@ if test -n "$GMP_CFLAGS" && test -z "$user_redefine_cc" ; then
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#ifndef __GNUC__
# error "GCC Not Found"
+error
#endif
]])], [
GCC=yes
@@ -141,6 +142,7 @@ AC_MSG_CHECKING(for ICC)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#if !defined(__ICC)
# error "ICC Not Found"
+error
#endif
]], [[]])],[
AC_MSG_RESULT(yes)
@@ -212,6 +214,7 @@ case $host in
#include "gmp.h"
#if !__GMP_LIBGMP_DLL
# error "Dead man"
+error
#endif
]], [[]])],[AC_MSG_RESULT(DLL)],[
AC_MSG_RESULT(static)
@@ -221,6 +224,7 @@ case $host in
#include "gmp.h"
#if __GMP_LIBGMP_DLL
# error "Dead man"
+error
#endif
]], [[]])],[AC_MSG_RESULT(static)],[
AC_MSG_RESULT(DLL)
@@ -250,6 +254,7 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
#include "gmp.h"
#if (__GNU_MP_VERSION*100+__GNU_MP_VERSION_MINOR*10 < 410)
# error "min GMP version is 4.1.0"
+error
#endif
]])],[AC_MSG_RESULT(yes)],[
AC_MSG_RESULT(no)