summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2006-11-24 00:44:20 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2006-11-24 00:44:20 +0000
commit5f64d497132e70dd612517199e809bba4fe226cf (patch)
tree3f8debf4c3908573954d1c6dd5869b92975492fa /configure.in
parent414684147b75212df86eb17fb73b522fa3b420dd (diff)
downloadmpfr-5f64d497132e70dd612517199e809bba4fe226cf.tar.gz
configure.in: check for gmp.h a bit earlier.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@4279 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 797b298e9..d3123489f 100644
--- a/configure.in
+++ b/configure.in
@@ -252,6 +252,19 @@ if test "${with_tags+set}" != set; then
with_tags=
fi
+dnl
+dnl Setup GMP detection
+dnl
+
+dnl Check GMP Header
+AC_MSG_CHECKING(for gmp.h)
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+#include "gmp.h"
+]])],[AC_MSG_RESULT(yes)],[
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([gmp.h can't be found, or is unusable.])
+])
+
dnl Configs for Windows DLLs.
dnl libtool requires "-no-undefined" for win32 dll
dnl It also disables the tests involving the linking with LIBGMP if DLL
@@ -296,18 +309,9 @@ GMP_C_ATTRIBUTE_MODE
dnl
-dnl Setup GMP detection
+dnl Setup GMP detection (continued)
dnl
-dnl Check GMP Header
-AC_MSG_CHECKING(for gmp.h)
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
-#include "gmp.h"
-]])],[AC_MSG_RESULT(yes)],[
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([gmp.h can't be found, or is unusable.])
-])
-
AC_MSG_CHECKING(for recent GMP)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
#include "gmp.h"