summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpelissip <pelissip@280ebfd0-de03-0410-8827-d642c229c3f4>2005-02-09 14:11:13 +0000
committerpelissip <pelissip@280ebfd0-de03-0410-8827-d642c229c3f4>2005-02-09 14:11:13 +0000
commitef677ab36d7329ddcb8a08e388f9575a4d8d349e (patch)
tree13e435a3315200c023971807de76201bde6f2b57 /configure.in
parent8c1327f9356fa14f2d93823532deaa9cb8a069b7 (diff)
downloadmpfr-ef677ab36d7329ddcb8a08e388f9575a4d8d349e.tar.gz
Reduce the tested compiler for C++ and Fortran to the minimum.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@3285 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 01b2c1970..20699652e 100644
--- a/configure.in
+++ b/configure.in
@@ -186,6 +186,11 @@ MPFR_CONFIGS
dnl
dnl Setup LIBTOOL
dnl
+dnl Currently libtool always detect a C++ and fortran compiler
+dnl Reduce the search list to g++ and g77
+dnl It may freeze with cl on some systems
+AC_PROG_CXX([g++])
+AC_PROG_F77([g77])
dnl Configs for Windows DLLs.
dnl libtool requires "-no-undefined" for win32 dll
@@ -270,6 +275,10 @@ AC_CHECK_LIB(gmp, __gmp_version, [LIBS="-lgmp $LIBS"],
[AC_MSG_ERROR(libgmp not found)])
dnl Check if we can use internal header files of GMP.
+dnl TODO: Check for this before including libgmp,
+dnl and remove sub_nc test after (setting gmp_internal)
+dnl TODO: Static and dynamic lib may be different. static may work
+dnl while dynamic not (according to include) and vice-versa.
AC_MSG_CHECKING(for gmp internal files)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
#include "gmp.h"