summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorthevenyp <thevenyp@280ebfd0-de03-0410-8827-d642c229c3f4>2008-02-12 12:52:35 +0000
committerthevenyp <thevenyp@280ebfd0-de03-0410-8827-d642c229c3f4>2008-02-12 12:52:35 +0000
commit48f3cd34edf7b095de0978b4c01640c8a82b8428 (patch)
tree641d1d093516a2c5fc00140a72fb61a382ede814 /tests/Makefile.am
parent7a316214ba08556a8e76eeb4c791edaf4481b6cf (diff)
downloadmpfr-48f3cd34edf7b095de0978b4c01640c8a82b8428.tar.gz
rename tprintf.c as tsprintf.c, because it does not deal with mpfr_printf.
add tests for mpfr_fprintf functions git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@5274 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 60ef8903a..817c8f496 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,22 @@
AUTOMAKE_OPTIONS = 1.6 gnu $(top_builddir)/ansi2knr
-check_PROGRAMS = tversion tinternals tinits tisqrt tsgn tcheck tisnan texceptions tset_exp tset tabs tset_d tset_f tset_q tset_si tset_str tset_z tset_ld tset_sj tswap tcopysign tcmp tcmp2 tcmpabs tcmp_d tcmp_ld tcomparisons teq tadd tsub tmul tdiv tsub1sp tadd1sp tadd_ui tsub_ui tcmp_ui tdiv_ui tmul_ui tsqrt_ui tui_div tui_sub tadd_d tsub_d td_sub tmul_d tdiv_d td_div tgmpop tsi_op tmul_2exp tfma tfms tsum tdim tminmax tnext tfits tget_d tget_d_2exp tget_z tget_str tget_sj tout_str tinp_str toutimpl tcan_round tround_prec tsqrt tconst_log2 tconst_pi tconst_euler trandom ttrunc trint tfrac tmodf texp texp2 texp10 texpm1 tlog tlog2 tlog10 tlog1p tpow tui_pow tpow3 tcosh tsinh ttanh tsinh_cosh tacosh tasinh tatanh thyperbolic tasin tacos tcos tatan tsin ttan tsin_cos tagm thypot tfactorial tgamma terf tcbrt tzeta mpf_compat mpfr_compat reuse tsqr tstrtofr tpow_z tget_f tconst_catalan troot tsec tcsc tcot teint tcoth tcsch tsech tstckintc tsubnormal tlngamma tlgamma tzeta_ui tget_ld_2exp tget_set_d64 tj0 tj1 tjn ty0 ty1 tyn tremquo tfmod tl2b tli2 tprintf trec_sqrt
+check_PROGRAMS = tversion tinternals tinits tisqrt tsgn tcheck tisnan \
+ texceptions tset_exp tset tabs tset_d tset_f tset_q tset_si tset_str \
+ tset_z tset_ld tset_sj tswap tcopysign tcmp tcmp2 tcmpabs tcmp_d \
+ tcmp_ld tcomparisons teq tadd tsub tmul tdiv tsub1sp tadd1sp tadd_ui \
+ tsub_ui tcmp_ui tdiv_ui tmul_ui tsqrt_ui tui_div tui_sub tadd_d \
+ tsub_d td_sub tmul_d tdiv_d td_div tgmpop tsi_op tmul_2exp tfma tfms \
+ tsum tdim tminmax tnext tfits tget_d tget_d_2exp tget_z tget_str \
+ tget_sj tout_str tinp_str toutimpl tcan_round tround_prec tsqrt \
+ tconst_log2 tconst_pi tconst_euler trandom ttrunc trint tfrac tmodf \
+ texp texp2 texp10 texpm1 tlog tlog2 tlog10 tlog1p tpow tui_pow tpow3 \
+ tcosh tsinh ttanh tsinh_cosh tacosh tasinh tatanh thyperbolic tasin \
+ tacos tcos tatan tsin ttan tsin_cos tagm thypot tfactorial tgamma \
+ terf tcbrt tzeta mpf_compat mpfr_compat reuse tsqr tstrtofr tpow_z \
+ tget_f tconst_catalan troot tsec tcsc tcot teint tcoth tcsch tsech \
+ tstckintc tsubnormal tlngamma tlgamma tzeta_ui tget_ld_2exp \
+ tget_set_d64 tj0 tj1 tjn ty0 ty1 tyn tremquo tfmod tl2b tli2 \
+ tsprintf tfprintf trec_sqrt
EXTRA_DIST = tgeneric.c tgeneric_ui.c mpf_compat.h inp_str.data