summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2011-10-14 10:13:34 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2011-10-14 10:13:34 +0000
commitb220cf7c66942cd361a38f1750d1ee1d22845669 (patch)
treee940fe665eeeeec2eaf058f46b989ce94fb3b3d2 /tests/Makefile.am
parentb86ddb38f55e5568dbfa5930a9cc681e9a35bf5d (diff)
downloadmpfr-b220cf7c66942cd361a38f1750d1ee1d22845669.tar.gz
[tests/Makefile.am] Added -L$(top_builddir)/src/.libs to AM_LDFLAGS.
[INSTALL] Removed the notes on HP-UX (obsolete after the above change). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@7920 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 96892c1bd..b85bbc7a1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -65,8 +65,24 @@ $(top_builddir)/src/libmpfr.la:
TESTS = $(check_PROGRAMS)
TESTS_ENVIRONMENT = MPFR_QUIET=1 $(VALGRIND)
-# Option to prevent libtool from generating wrapper scripts for the tests.
+# The -no-install option prevents libtool from generating wrapper scripts
+# for the tests.
# This is useful to easily run the test scripts under valgrind or gdb.
# See discussion http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/28033
# http://article.gmane.org/gmane.comp.lib.gnulib.bugs/28140 in particular.
-AM_LDFLAGS = -no-install
+#
+# The -L$(top_builddir)/src/.libs option is necessary for some platforms,
+# such as HP-UX, when --with-gmp or --with-gmp-lib is used and an old MPFR
+# library is already installed in the corresponding lib directory: its
+# purpose is to make sure that the local .libs comes first in the library
+# search path (otherwise the tests are linked against the old MPFR library
+# by the LINK command -- see the generated Makefile). See:
+# http://websympa.loria.fr/wwsympa/arc/mpfr/2011-10/msg00042.html
+# http://websympa.loria.fr/wwsympa/arc/mpfr/2011-10/msg00043.html
+# http://websympa.loria.fr/wwsympa/arc/mpfr/2011-10/msg00044.html
+# http://websympa.loria.fr/wwsympa/arc/mpfr/2011-10/msg00066.html
+# http://websympa.loria.fr/wwsympa/arc/mpfr/2011-10/msg00065.html
+# and
+# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=9728
+#
+AM_LDFLAGS = -no-install -L$(top_builddir)/src/.libs