summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorthevenyp <thevenyp@280ebfd0-de03-0410-8827-d642c229c3f4>2008-12-11 15:20:56 +0000
committerthevenyp <thevenyp@280ebfd0-de03-0410-8827-d642c229c3f4>2008-12-11 15:20:56 +0000
commitfcfa60068f073b4e47d60ef5d4aefd2bba507674 (patch)
tree6f480d111dce8399b6a9b26e84daff4f2af30a64 /tests/Makefile.am
parent99bc058511216843de15695f81ad96cd68ab1151 (diff)
downloadmpfr-fcfa60068f073b4e47d60ef5d4aefd2bba507674.tar.gz
configure.in: Add AM_PROG_CC_C_O needed by tmul_CPPFLAGS.
tests/Makefile.am: Add tmul.dat in EXTRA_DIST and pass srcdir to tmul.c through tmul_CPPFLAGS. tests/tmul.c: Add path to tmul.dat. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@5710 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index aa5cdaa4d..538276171 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,7 +18,9 @@ check_PROGRAMS = tversion tinternals tinits tisqrt tsgn tcheck tisnan \
tget_set_d64 tj0 tj1 tjn ty0 ty1 tyn tremquo tfmod tl2b tli2 tprintf \
tsprintf tfprintf trec_sqrt tpow_all
-EXTRA_DIST = tgeneric.c tgeneric_ui.c mpf_compat.h inp_str.data
+EXTRA_DIST = tgeneric.c tgeneric_ui.c mpf_compat.h inp_str.data tmul.dat
+
+tmul_CPPFLAGS = -D__SRCDIR=$(srcdir)
LDADD = libfrtests.la $(MPFR_LIBM) $(top_builddir)/libmpfr.la
INCLUDES = -I$(top_srcdir) -I$(top_builddir)