summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b05e35c79..5ea250392 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -83,11 +83,15 @@ $(top_builddir)/src/libmpfr.la:
TESTS = $(check_PROGRAMS)
+# Unset DISPLAY as it is not needed and it can yield error messages when
+# running the tests with LOG_COMPILER=wine (for builds with MinGW). See:
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=914822
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=914949
# $(VALGRIND) is still there to be able to use a wrapper such as valgrind
# in case old Automake. With Automake 1.13+, where a parallel test harness
# is generated, use LOG_COMPILER instead. For additional information, see:
# http://www.gnu.org/software/automake/manual/automake.html#Parallel-Test-Harness
-TESTS_ENVIRONMENT = MPFR_QUIET=1 $(VALGRIND)
+TESTS_ENVIRONMENT = env -u DISPLAY MPFR_QUIET=1 $(VALGRIND)
# The -no-install option prevents libtool from generating wrapper scripts
# for the tests.