summaryrefslogtreecommitdiff
path: root/demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'demo/CMakeLists.txt')
-rw-r--r--demo/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/demo/CMakeLists.txt b/demo/CMakeLists.txt
new file mode 100644
index 0000000..4807f16
--- /dev/null
+++ b/demo/CMakeLists.txt
@@ -0,0 +1,29 @@
+#
+# Demonstration CMakeLists.txt for nanomsg demos.
+#
+# This file shows how one might use nanomsg from a another project
+# that is also CMake-driven.
+#
+# Thanks for the idea goes to @maddouri.
+#
+cmake_minimum_required (VERSION 2.8.7)
+
+project(nanomsg-demo)
+
+# Call this from your own project's makefile.
+find_package(nanomsg CONFIG REQUIRED)
+
+add_executable(async_demo async_demo.c)
+target_link_libraries(async_demo nanomsg)
+
+add_executable(device_demo device_demo.c)
+target_link_libraries(device_demo nanomsg)
+
+add_executable(pthread_demo pthread_demo.c)
+target_link_libraries(pthread_demo nanomsg)
+
+add_executable(pubsub_demo pubsub_demo.c)
+target_link_libraries(pubsub_demo nanomsg)
+
+add_executable(rpc_demo rpc_demo.c)
+target_link_libraries(rpc_demo nanomsg)