summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaciej Stachowiak <mstachow@src.gnome.org>2001-03-21 05:15:42 +0000
committerMaciej Stachowiak <mstachow@src.gnome.org>2001-03-21 05:15:42 +0000
commit9b2202c13fbaaa5705496a894fdb6a326134f827 (patch)
tree2fc506c408dd6af12f8159299515b97f1da196a0 /Makefile.am
parent88b3ea09abf74b84d0fba4591c0f02bf6dc1a1a2 (diff)
downloadnautilus-9b2202c13fbaaa5705496a894fdb6a326134f827.tar.gz
reviewed by: Ian McKellar <ian@eazel.com>
* Makefile.am, configure.in, nautilus-config.in, nautilus.spec.in, nautilusConf.sh.in, .cvsignore: Add nautilus-config and nautilusConf.sh so other modules can sensibly depend on libnautilus (this fix should make it into 1.0.2, I guess I should file a bug at some point).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 48290bb94..2eb25f055 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,8 @@ EXTRA_DIST= \
nautilus.desktop \
nautilus.desktop.in \
nautilus-launch-icon.png \
+ nautilusConf.sh.in \
+ nautilus-config.in \
ChangeLog-20000414 \
ChangeLog-20000625 \
ChangeLog-20000831 \
@@ -62,6 +64,40 @@ appicon_DATA = nautilus-launch-icon.png
Applicationsdir = $(datadir)/gnome/apps/Applications
Applications_DATA = $(DESKTOP_FILES)
+
+
+## [The following is shamelessly copied from gnome-vfs.]
+
+## We create `nautilusConf.sh' here and not from configure because we
+## want to get the paths expanded correctly. Macros like srcdir are
+## given the value NONE in configure if the user doesn't specify them
+## (this is an autoconf feature, not a bug).
+
+bin_SCRIPTS = $(top_builddir)/nautilus-config
+
+confexecdir=$(libdir)
+confexec_DATA = \
+ nautilusConf.sh \
+ $(NULL)
+
+nautilusConf.sh: nautilusConf.sh.in Makefile
+ sed -e 's?\@NAUTILUS_LIBDIR\@?$(NAUTILUS_LIBDIR)?g' \
+ -e 's?\@NAUTILUS_INCLUDEDIR\@?$(NAUTILUS_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ -e 's?\@NAUTILUS_LIBS\@?$(NAUTILUS_LIBS)?g' \
+ < $(srcdir)/nautilusConf.sh.in > nautilusConf.tmp \
+ && mv nautilusConf.tmp nautilusConf.sh
+
+nautilus-config: nautilus-config.in Makefile
+ sed -e 's?\@LIBDIR\@?$(libdir)?g' \
+ -e 's?\@NAUTIlUS_LIBDIR\@?$(NAUTILUS_LIBDIR)?g' \
+ -e 's?\@NAUTILUS_INCLUDEDIR\@?$(NAUTILUS_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ -e 's?\@NAUTILUS_LIBS\@?$(NAUTILUS_LIBS)?g' \
+ < $(srcdir)/nautilus-config.in > nautilus-config.tmp \
+ && mv nautilus-config.tmp nautilus-config && \
+ chmod 755 nautilus-config
+
##################################################################
#
# eazel-logos/*, if it exists