summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDarin Adler <darin@src.gnome.org>2001-10-05 23:28:55 +0000
committerDarin Adler <darin@src.gnome.org>2001-10-05 23:28:55 +0000
commite5afc6511c701d715ad264de9f36fd2fe27a86e0 (patch)
treeb21f48f17fb56ff08d3fcf60114337dfe6e496a9 /Makefile.am
parente1ccd6d519e0525d73da358359f37bceb77b23ef (diff)
downloadnautilus-e5afc6511c701d715ad264de9f36fd2fe27a86e0.tar.gz
removed Remove the code to look for Eazel logos.
* eazel-logos: removed * libnautilus-private/nautilus-file-utilities.c: (nautilus_pixmap_file): Remove the code to look for Eazel logos. * configure.in: * Makefile.am: * nautilus.spec.in: Remove the code to include the Eazel logos in the tarball and the package. * HACKING: Remove the instructions on how to omit the Eazel logos.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am85
1 files changed, 0 insertions, 85 deletions
diff --git a/Makefile.am b/Makefile.am
index be853d4ca..64ef613f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,54 +103,6 @@ nautilus-config: nautilus-config.in Makefile
##################################################################
#
-# eazel-logos/*, if it exists
-#
-##################################################################
-
-icondir = $(datadir)/pixmaps/nautilus/eazel-logos
-
-if HAVE_EAZEL_LOGOS
-EAZEL_LOGOS_ICONS = \
- $(top_srcdir)/eazel-logos/LICENSE \
- $(top_srcdir)/eazel-logos/About_Image.png \
- $(top_srcdir)/eazel-logos/about_background.png \
- $(top_srcdir)/eazel-logos/default.xml \
- $(top_srcdir)/eazel-logos/druid_header.png \
- $(top_srcdir)/eazel-logos/eazel-logo-right-side-logo.png \
- $(NULL)
-endif
-
-##################################################################
-#
-# eazel-logos/throbber/*, if it exists
-#
-##################################################################
-
-throbberdir = $(datadir)/pixmaps/nautilus/eazel-logos/throbber
-
-if HAVE_EAZEL_LOGOS
-EAZEL_LOGOS_THROBBER = \
- $(top_srcdir)/eazel-logos/throbber/001.png \
- $(top_srcdir)/eazel-logos/throbber/002.png \
- $(top_srcdir)/eazel-logos/throbber/003.png \
- $(top_srcdir)/eazel-logos/throbber/004.png \
- $(top_srcdir)/eazel-logos/throbber/005.png \
- $(top_srcdir)/eazel-logos/throbber/006.png \
- $(top_srcdir)/eazel-logos/throbber/007.png \
- $(top_srcdir)/eazel-logos/throbber/008.png \
- $(top_srcdir)/eazel-logos/throbber/009.png \
- $(top_srcdir)/eazel-logos/throbber/010.png \
- $(top_srcdir)/eazel-logos/throbber/011.png \
- $(top_srcdir)/eazel-logos/throbber/012.png \
- $(top_srcdir)/eazel-logos/throbber/013.png \
- $(top_srcdir)/eazel-logos/throbber/014.png \
- $(top_srcdir)/eazel-logos/throbber/015.png \
- $(top_srcdir)/eazel-logos/throbber/rest.png \
- $(NULL)
-endif
-
-##################################################################
-#
# dist-hook
#
##################################################################
@@ -158,23 +110,6 @@ endif
dist-hook: nautilus.spec
cp nautilus.spec $(distdir)
-# This is ridiculous, but automake apparently won't allow conditionals
-# in EXTRA_DIST.
-
- mkdir -p $(distdir)/eazel-logos
- list='$(EAZEL_LOGOS_ICONS)'; \
- for i in $$list; \
- do \
- cp $$i $(distdir)/eazel-logos; \
- done
-
- mkdir -p $(distdir)/eazel-logos/throbber
- list='$(EAZEL_LOGOS_THROBBER)'; \
- for i in $$list; \
- do \
- cp $$i $(distdir)/eazel-logos/throbber; \
- done
-
##################################################################
#
# install-data-hook
@@ -189,23 +124,3 @@ install-data-hook: nautilus-clean.sh
$(INSTALL_PROGRAM) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p; \
else :; fi; \
done
-
-# This is slightly less ridiculous. I'm doing it this way instead of with
-# an automake DATA rule because it's easier to deal with the relative paths
-# like this.
-
- $(mkinstalldirs) $(icondir)
- @list='$(EAZEL_LOGOS_ICONS)'; \
- for i in $$list; \
- do \
- echo $(INSTALL_PROGRAM) $$i $(icondir)/`basename $$i`; \
- $(INSTALL_PROGRAM) $$i $(icondir)/`basename $$i`; \
- done
-
- $(mkinstalldirs) $(throbberdir)
- @list='$(EAZEL_LOGOS_THROBBER)'; \
- for i in $$list; \
- do \
- echo $(INSTALL_PROGRAM) $$i $(throbberdir)/`basename $$i`; \
- $(INSTALL_PROGRAM) $$i $(throbberdir)/`basename $$i`; \
- done