summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Fischer <eric@src.gnome.org>2001-02-14 23:17:56 +0000
committerEric Fischer <eric@src.gnome.org>2001-02-14 23:17:56 +0000
commit2cc5a63d467078f9ea324e6f61b5d044cbfabc71 (patch)
tree32f27df935ea74055e8404cf5ed9ed537cb16484 /Makefile.am
parentfcc4b07b0a409d4fc09d6073adb4c076add015b9 (diff)
downloadnautilus-2cc5a63d467078f9ea324e6f61b5d044cbfabc71.tar.gz
This is a bunch of changes leading up to Bug 6515, so
the installer can get built by just an extra flag to configure rather than its own script. * Makefile.am: Add nautilus-installer to SUBDIRS * acconfig.h: Add ENABLE_INSTALLER to things that can be configured * configure.in: Add --enable-installer command line flag. Set PACKAGE_SYSTEM_OBJECT and PACKAGE_SYSTEM_SOURCE based on whether rpm 3 or 4 is installed. Create nautilus-installer Makefiles * nautilus-installer/Makefile.am: Remove things that Robey said were no longer used. Add libtrilobite and install-lib to SUBDIRS that need to be built. * nautilus-installer/install-lib/Makefile.am: New Makefile that builds a second copy of the installer libraries with weird flags as needed by the installer. * nautilus-installer/libtrilobite/Makefile.am: New Makefile that builds a second copy of the trilobite libraries with weird flags as needed by the installer. * nautilus-installer/src/Makefile.am: Do in the Makefile what formerly had been done in link.sh (build the installer, and create a self-extracting version of it). * nautilus-installer/src/create-eazel-installer.sh: Script, adapted from what's in link.sh, to create a self-extracting installer.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8bbe05b38..c61745b36 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,7 @@ SUBDIRS = \
src \
components \
$(APPLETS_SUBDIRS) \
+ nautilus-installer \
test \
user-guide \
po \