summaryrefslogtreecommitdiff
path: root/components/mozilla/Makefile.am
diff options
context:
space:
mode:
authorGene Z. Ragan <gzr@eazel.com>2000-09-29 20:26:01 +0000
committerGene Ragan <gzr@src.gnome.org>2000-09-29 20:26:01 +0000
commit0cd5680034b35c1403ba84e9324102aed2854c73 (patch)
treed28fc12760780c874f1bdb114a8265565651f485 /components/mozilla/Makefile.am
parent5fb02ce1fadcb5e34937848c164bb2db58b11d28 (diff)
downloadnautilus-0cd5680034b35c1403ba84e9324102aed2854c73.tar.gz
Fixed bug 2602, Integrate gnome-vfs http proxy setting into Mozilla
2000-09-29 Gene Z. Ragan <gzr@eazel.com> Fixed bug 2602, Integrate gnome-vfs http proxy setting into Mozilla component. * components/mozilla/Makefile.am: * components/mozilla/nautilus-mozilla-content-view.c: (nautilus_mozilla_content_view_initialize): Check for proxy settings and init mozilla to use them. Fixed bug 2692, Need to let user specify a proxy for Mozilla component. * libnautilus-extensions/nautilus-global-preferences.c: (use_proxy_changed), (proxy_changed), (global_preferences_register): When the Nautilus preferences mechanism supports system wide settings, we should revisit this code and remove the gconf system prefs retrieval code.
Diffstat (limited to 'components/mozilla/Makefile.am')
-rw-r--r--components/mozilla/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/components/mozilla/Makefile.am b/components/mozilla/Makefile.am
index 29e618732..44eb701c2 100644
--- a/components/mozilla/Makefile.am
+++ b/components/mozilla/Makefile.am
@@ -14,6 +14,7 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_builddir) \
$(BONOBO_CFLAGS) \
+ $(GCONF_CFLAGS) \
$(GNOMEUI_CFLAGS) \
$(MOZILLA_COMPONENT_CFLAGS) \
-DMOZILLA_MILESTONE=$(MOZILLA_MILESTONE) \
@@ -42,6 +43,7 @@ noinst_HEADERS =\
nautilus_mozilla_content_view_LDADD = \
$(top_builddir)/libnautilus/libnautilus.la \
$(BONOBO_LIBS) \
+ $(GCONF_LIBS) \
$(GNOMEUI_LIBS) \
$(VFS_LIBS) \
$(OAF_LIBS) \