summaryrefslogtreecommitdiff
path: root/components/mozilla/Makefile.am
diff options
context:
space:
mode:
authorRamiro Estrugo <ramiro@src.gnome.org>2000-04-19 03:55:01 +0000
committerRamiro Estrugo <ramiro@src.gnome.org>2000-04-19 03:55:01 +0000
commit59a05291322062a0c3724029fd89e083ebb09cd6 (patch)
tree04912d0314ccdf43e74b1526e3e8926fa22afbb6 /components/mozilla/Makefile.am
parentc11ff76858a444ca3735cc12e2a9f1bd341d1c5d (diff)
downloadnautilus-59a05291322062a0c3724029fd89e083ebb09cd6.tar.gz
Add mozilla component skeleton to the nautilus build. This is
currently turned off by default and there is no way to turn it on. Soon there will be though.
Diffstat (limited to 'components/mozilla/Makefile.am')
-rw-r--r--components/mozilla/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/components/mozilla/Makefile.am b/components/mozilla/Makefile.am
new file mode 100644
index 000000000..809d2c285
--- /dev/null
+++ b/components/mozilla/Makefile.am
@@ -0,0 +1,39 @@
+# yes, i know its hardcoded
+
+CPPFLAGS = \
+ -DPREFIX=\"$(prefix)\"
+ -DG_LOG_DOMAIN=\"Nautilus-Mozilla\"
+
+INCLUDES = \
+ -I/builds/ramiro/s/mozilla/dist/include \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GNOMEUI_CFLAGS) \
+ $(WERROR)
+
+gnorbadir = $(sysconfdir)/CORBA/servers
+
+gnorba_DATA = \
+ nautilus-mozilla-content-view.goad
+
+
+bin_PROGRAMS = \
+ nautilus-mozilla-content-view
+
+nautilus_mozilla_content_view_SOURCES = \
+ nautilus-mozilla-content-view.c \
+ main.c
+
+nautilus_mozilla_content_view_LDFLAGS = \
+ $(top_builddir)/nautilus-widgets/libnautilus-widgets.la \
+ $(top_builddir)/libnautilus/libnautilus.la \
+ $(BONOBO_LIBS) \
+ $(GNOMEUI_LIBS) \
+ $(VFS_LIBS) \
+ $(GNORBA_LIBS) \
+ -L/builds/ramiro/s/mozilla/dist/bin \
+ -lgtkembedmoz \
+ -lgtksuperwin
+
+
+EXTRA_DIST = nautilus-mozilla-content-view.goad