summaryrefslogtreecommitdiff
path: root/components/mozilla/Makefile.am
diff options
context:
space:
mode:
authorRamiro Estrugo <ramiro@src.gnome.org>2000-04-19 10:05:14 +0000
committerRamiro Estrugo <ramiro@src.gnome.org>2000-04-19 10:05:14 +0000
commitcf496b8e0a24d60e1f770c396394bd41b0188645 (patch)
tree02dc4698dcdb4841555ce93c56196003cad1f1f1 /components/mozilla/Makefile.am
parentfef6546735105a7fbb9c58bcd381f12fa6394f80 (diff)
downloadnautilus-cf496b8e0a24d60e1f770c396394bd41b0188645.tar.gz
Add voodoo to support --with-mozilla.
* configure.in: Add voodoo to support --with-mozilla. * components/Makefile.am: Add conditional build of mozilla subdir. * components/mozilla/Makefile.am: Un-hardcode cflags and libs. Use the values set in configure instead.
Diffstat (limited to 'components/mozilla/Makefile.am')
-rw-r--r--components/mozilla/Makefile.am64
1 files changed, 33 insertions, 31 deletions
diff --git a/components/mozilla/Makefile.am b/components/mozilla/Makefile.am
index 3ed60aa12..a9b357247 100644
--- a/components/mozilla/Makefile.am
+++ b/components/mozilla/Makefile.am
@@ -1,41 +1,43 @@
-# yes, i know its hardcoded
+NULL =
-CPPFLAGS = \
- -DPREFIX=\"$(prefix)\"
+CPPFLAGS = \
+ -DPREFIX=\"$(prefix)\" \
-DG_LOG_DOMAIN=\"Nautilus-Mozilla\"
-INCLUDES = \
- -I/home/ramiro/b/sekhmet/s/mozilla/dist/include \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- $(GNOMEUI_CFLAGS) \
- $(WERROR)
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GNOMEUI_CFLAGS) \
+ $(WERROR) \
+ $(MOZILLA_COMPONENT_CFLAGS) \
+ $(NULL)
gnorbadir = $(sysconfdir)/CORBA/servers
-gnorba_DATA = \
- nautilus-mozilla-content-view.goad
+gnorba_DATA = \
+ nautilus-mozilla-content-view.goad \
+ $(NULL)
+bin_PROGRAMS =\
+ nautilus-mozilla-content-view \
+ $(NULL)
-bin_PROGRAMS = \
- nautilus-mozilla-content-view
+nautilus_mozilla_content_view_SOURCES = \
+ nautilus-mozilla-content-view.c \
+ main.c \
+ $(NULL)
-nautilus_mozilla_content_view_SOURCES = \
- nautilus-mozilla-content-view.c \
- main.c
-
-nautilus_mozilla_content_view_LDFLAGS = \
- $(top_builddir)/libnautilus/libnautilus.la \
- $(BONOBO_LIBS) \
- $(GNOMEUI_LIBS) \
- $(VFS_LIBS) \
+nautilus_mozilla_content_view_LDFLAGS = \
+ $(top_builddir)/libnautilus/libnautilus.la \
+ $(BONOBO_LIBS) \
+ $(GNOMEUI_LIBS) \
+ $(VFS_LIBS) \
$(GNORBA_LIBS) \
- -L/home/ramiro/b/sekhmet/s/mozilla/dist/bin \
- -lgtkembedmoz \
- -lgtksuperwin \
- -lxpcom \
- -lnspr4 \
- -lplc4 \
- -lplds4
-
-EXTRA_DIST = nautilus-mozilla-content-view.goad
+ $(MOZILLA_COMPONENT_LDFLAGS) \
+ $(MOZILLA_COMPONENT_LIBS) \
+ $(NULL)
+
+EXTRA_DIST = \
+ nautilus-mozilla-content-view.goad \
+ $(NULL)
+