summaryrefslogtreecommitdiff
path: root/components/sample/Makefile.am
diff options
context:
space:
mode:
authorDarin Adler <darin@src.gnome.org>2001-08-31 22:19:08 +0000
committerDarin Adler <darin@src.gnome.org>2001-08-31 22:19:08 +0000
commit0e323670e50745e2cd235344225f6ccb80475e4d (patch)
treef8a6f1361369f73c6ebf9d4ea6bcee4ab8081acd /components/sample/Makefile.am
parent579b34d672b5a0faa3f3d49383341b7d64d4eb1a (diff)
downloadnautilus-0e323670e50745e2cd235344225f6ccb80475e4d.tar.gz
Don't link in the libnautilus-private library for components that don't
* components/adapter/Makefile.am: * components/image-viewer/Makefile.am: * components/loser/content/Makefile.am: * components/loser/sidebar/Makefile.am: Don't link in the libnautilus-private library for components that don't use it. * components/sample/Makefile.am: Pretty up the sample a bit. Don't link with GConf since we're not using it directly. * components/shell/shell.oafinfo: Remove this obsolete file. * components/news/nautilus-news.c: (draw_rss_items): Fix a leak by unref'ing the text layout object instead of just destroying it. * src/nautilus-complex-search-bar.c: (search_bar_criterion_type_changed_callback): Fix leak of the criterion object by sinking it instead of destroying it. The criterion object seems to be a widget that's never used as one. It should be a GtkObject instead. * src/nautilus-location-bar.c: (nautilus_location_bar_set_location): Simplified code a bit by getting rid of special cases for NULL.
Diffstat (limited to 'components/sample/Makefile.am')
-rw-r--r--components/sample/Makefile.am41
1 files changed, 18 insertions, 23 deletions
diff --git a/components/sample/Makefile.am b/components/sample/Makefile.am
index a7f66f142..4104781b9 100644
--- a/components/sample/Makefile.am
+++ b/components/sample/Makefile.am
@@ -1,48 +1,43 @@
-
# WHAT YOU NEED TO CHANGE: Change all the filenames to refer to your
# component. Also add whatever libraries, include paths, etc you want,
# and change the G_LOG_DOMAIN.
-# (does not include nautilus Makefile.shared so it's usable outside nautilus)
NULL =
-INCLUDES = \
- -DG_LOG_DOMAIN=\"Nautilus-Sample\" \
- -DDATADIR=\"$(datadir)\" \
- -DICON_DIR=\"$(datadir)/pixmaps/nautilus\" \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- $(GNOMEUI_CFLAGS) \
- $(BONOBO_CFLAGS) \
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"Nautilus-Sample\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DICON_DIR=\"$(datadir)/pixmaps/nautilus\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GNOMEUI_CFLAGS) \
+ $(BONOBO_CFLAGS) \
$(OAF_CFLAGS)
-bin_PROGRAMS = \
+bin_PROGRAMS = \
nautilus-sample-content-view
-nautilus_sample_content_view_SOURCES = \
- nautilus-sample-content-view.h \
- nautilus-sample-content-view.c \
+nautilus_sample_content_view_SOURCES = \
+ nautilus-sample-content-view.h \
+ nautilus-sample-content-view.c \
main.c
-nautilus_sample_content_view_LDADD = \
+nautilus_sample_content_view_LDADD = \
$(top_builddir)/libnautilus/libnautilus.la \
- $(BONOBO_LIBS) \
- $(BONOBOX_LIBS) \
- $(GCONF_LIBS) \
- $(VFS_LIBS) \
- $(LIBRSVG_LIBS) \
+ $(BONOBO_LIBS) \
+ $(BONOBOX_LIBS) \
+ $(VFS_LIBS) \
$(OAF_LIBS)
uidir = $(datadir)/gnome/ui
ui_DATA = nautilus-sample-content-view-ui.xml
oafdir = $(datadir)/oaf
-oaf_in_files = \
- Nautilus_View_sample.oaf.in \
+oaf_in_files = \
+ Nautilus_View_sample.oaf.in \
$(NULL)
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
@XML_I18N_MERGE_OAF_RULE@
-
EXTRA_DIST = $(oaf_in_files) $(oaf_DATA) $(ui_DATA)