summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Soriano <csoriano@gnome.org>2015-02-26 17:22:01 +0100
committerCarlos Soriano <csoriano@gnome.org>2015-02-26 17:25:42 +0100
commit7dfbb8b73a584114dfee7d62fbcc6c8e0f208ed8 (patch)
treeab1463e30b48208be13a8d68ab720c656e5275ad /configure.ac
parent46aa964644213b9acd5b703c1dac7af29046f743 (diff)
downloadnautilus-7dfbb8b73a584114dfee7d62fbcc6c8e0f208ed8.tar.gz
configure: enable debug always
We can control the debug output with G_MESSAGES_DEBUG anyway, and is off by default. Probably we were doing this to avoid the compilation and performance impact of the debug stuff, but that shouldn't be a real problem these days. This also allows to the final user run the application with debug without the need of building the application.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 1a1481529..4eb5f8d5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,24 +69,6 @@ dnl ==========================================================================
GTK_DOC_CHECK([1.4])
dnl ==========================================================================
-
-AC_ARG_ENABLE(debug,
- AS_HELP_STRING([--disable-debug],[Disable debugging code]),
- [
- case "${enableval}" in
- yes|no) enable_debug="${enableval}" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
- esac
- ],
- [enable_debug=yes])
-
-if test "$enable_debug" = yes; then
- AC_DEFINE(ENABLE_DEBUG, [], [Enable debug code])
-else
- enable_debug=no
-fi
-
-dnl ==========================================================================
dnl Enable Profiling
AC_ARG_ENABLE(profiling,
@@ -352,7 +334,6 @@ nautilus-$VERSION:
nautilus-sendto ext: $enable_nst_extension
Tracker support: $enable_tracker
- debugging support: ${enable_debug}
profiling support: ${enable_profiling}
nautilus-extension documentation: ${enable_gtk_doc}
nautilus-extension introspection: ${found_introspection}