summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Soriano <csoriano@gnome.org>2015-07-22 00:05:53 +0200
committerCarlos Soriano <csoriano@gnome.org>2015-07-22 13:02:04 +0200
commitff6ccbaf40afe9cde56746990888246ac3fdd177 (patch)
treee021f62d3a92a74c3a84007326e3c7b95aa7af6a /configure.ac
parent902cac93a1748e7d2029c626c16d88d91b8c336e (diff)
downloadnautilus-ff6ccbaf40afe9cde56746990888246ac3fdd177.tar.gz
search: done loading signal only if not restarting engine
It was working as: - Search directory starts a new search - Search engine starts all search providers, each one in its own thread. - User changes query - Search engine stops all search providers - Searchs providers, since they are in its own thread, cancel in a unknown time. - Search directory starts a new search, even before all providers are finished. - Search engine is marked as need to restart. - Search providers finished. - Search engine emits finished signal, since all search providers now are stopped. - Clients doesn't have a way to know if the engine actually finished searching the current search, or the previous search that the client asked to stop. That might confuse clients if they ask for results. - Search engine restart the search providers without noticing the client, that thinks that the latest search it started was finished already. So to fix this confusion, only report that the engine actually finished if the engine is not going to restart the search providers. In this way a client can start a batch of consecutive searches without the risk of getting search finished signals from previous searches. Clients now will always get the search-finished signal of the latest search they started.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8efaf872b..286f61d9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -283,6 +283,7 @@ m4_ifdef([GOBJECT_INTROSPECTION_CHECK],
dnl ==========================================================================
AC_PATH_PROG(UPDATE_MIME_DATABASE, update-mime-database, no)
+AC_PATH_PROG(GLIB_MKENUMS, glib-mkenums)
AC_ARG_ENABLE(update-mimedb,
AS_HELP_STRING([--disable-update-mimedb],