summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-12-01 22:42:05 -0500
committerMatthias Clasen <mclasen@redhat.com>2013-12-01 22:42:05 -0500
commit0e0732cec0adc53e1f72697a69a4808373ce326e (patch)
treeba7b368b1bcabd3ca9644041ccdaf9e240f7eacb /configure.ac
parentc2a5e05231ea0743ef89e666c37a0a77534b9573 (diff)
downloadnautilus-0e0732cec0adc53e1f72697a69a4808373ce326e.tar.gz
Keep nautilus building with tracker 0.16
We still have tracker 0.16 in jhbuild, so we have to keep nautilus building with that version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7348f06e6..567963dbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -249,7 +249,11 @@ AC_ARG_ENABLE(tracker,
[enable_tracker=yes])
if test "x$enable_tracker" != "xno"; then
- PKG_CHECK_MODULES(TRACKER, tracker-sparql-0.18)
+ if $PKG_CONFIG --exists tracker-sparql-0.18; then
+ PKG_CHECK_MODULES(TRACKER, tracker-sparql-0.18)
+ else
+ PKG_CHECK_MODULES(TRACKER, tracker-sparql-0.16)
+ fi
AC_DEFINE(ENABLE_TRACKER, 1, [Define to enable Tracker support])
fi