summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrés G. Aragoneses <knocte@gmail.com>2013-06-18 15:45:14 +0200
committerCosimo Cecchi <cosimoc@gnome.org>2014-02-17 13:16:37 -0800
commitcea06af55baf8a2644c1b1afd6fe6d09c813dbc2 (patch)
treefea6619c201805458405ef41761148b63f8a5006 /configure.ac
parenta23ed4ad0173ca7a51e26282b85d06ce4b25912a (diff)
downloadnautilus-cea06af55baf8a2644c1b1afd6fe6d09c813dbc2.tar.gz
configure: check for introspection macro before calling it
In case the person building nautilus didn't have introspection, autoconf was not failing when finding the call to GOBJECT_INTROSPECTION_CHECK. After, automake would throw this kind of cryptic message (which hints about introspection not being present, but also smells like a bug in the autotools scripts waiting to be fixed): ... eel/Makefile.am: installing './depcomp' parallel-tests: installing './test-driver' libnautilus-extension/Makefile.am:67: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL We can improve this by checking if the macro is defined before calling it, which would then not pose any problem in case the user wants to build without introspection support. https://bugzilla.gnome.org/show_bug.cgi?id=702554
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85c2cb88f..b9fa84d9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -295,7 +295,9 @@ AC_CHECK_HEADERS([X11/XF86keysym.h])
##################################################
# Check for introspection
##################################################
-GOBJECT_INTROSPECTION_CHECK([0.6.4])
+m4_ifdef([GOBJECT_INTROSPECTION_CHECK],
+ [GOBJECT_INTROSPECTION_CHECK([0.6.4])],
+ [AM_CONDITIONAL(HAVE_INTROSPECTION, false)])
dnl ==========================================================================