summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMathieu Lacage <mathieu@eazel.com>2000-10-31 23:11:57 +0000
committerMathieu Lacage <mathieu@src.gnome.org>2000-10-31 23:11:57 +0000
commita8032294163ffcaf4b1274eb6b6d7ea0af7e5e37 (patch)
treec4cabdbc0a543dbb0e5860f4d217e9e6430280fb /configure.in
parent62f2884b6e97650560497d42a5f662b972523adb (diff)
downloadnautilus-a8032294163ffcaf4b1274eb6b6d7ea0af7e5e37.tar.gz
add new directories.
2000-10-31 Mathieu Lacage <mathieu@eazel.com> add new directories. * applets/.cvsignore: * applets/launcher/.cvsignore: * applets/Makefile.am: * applets/launcher/Makefile.am: stupid applet which is used during installation to display a nautilus icon on the user's panel. * applets/launcher/nautilus-icon-applet.c: (applet_change_pixel_size), (main): add checks for the libapplet library. * configure.in:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2e0f46cad..946ed6925 100644
--- a/configure.in
+++ b/configure.in
@@ -443,7 +443,7 @@ AC_MSG_ERROR([
*** Gtk+ 1.2.0 or better is required. The latest version of GTK
*** is always available from ftp://ftp.gtk.org/.]))
-AM_PATH_GNOME(1.0.0,,AC_MSG_ERROR([*** GNOME 1.0.0 or better is required.]), gnomecanvaspixbuf bonobo bonobox bonobox_print vfs idl)
+AM_PATH_GNOME(1.0.0,,AC_MSG_ERROR([*** GNOME 1.0.0 or better is required.]), gnomecanvaspixbuf bonobo bonobox bonobox_print vfs idl )
AC_SUBST(GNOMECANVASPIXBUF_LIBS)
AC_SUBST(GNOMECANVASPIXBUF_INCLUDEDIR)
@@ -497,6 +497,33 @@ dnl ====================================
dnl = End ghttp checks
dnl ====================================
+
+dnl ====================================
+dnl = begin applet checks
+dnl ====================================
+AC_MSG_CHECKING(for applets)
+APPLETS_CFLAGS=""
+APPLETS_LIBS=""
+HAVE_APPLETS="no"
+
+if test -n `gnome-config --modversion applets` ; then
+ HAVE_APPLETS="yes"
+ APPLETS_CFLAGS=`gnome-config --cflags applets`
+ APPLETS_LIBS=`gnome-config --libs applets`
+ AC_MSG_RESULT(yes)
+else
+ HAVE_APPLETS="no"
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR(Could not find applets library. Make sure you have installed the gnome-core package.)
+fi
+
+AC_SUBST(HAVE_APPLETS)
+AC_SUBST(APPLETS_CFLAGS)
+AC_SUBST(APPLETS_LIBS)
+dnl ====================================
+dnl = begin applet checks
+dnl ====================================
+
dnl ====================================
dnl = begin gdk-pixbuf checks
dnl ====================================
@@ -748,6 +775,8 @@ intl/Makefile
test/Makefile
user-guide/Makefile
user-guide/C/Makefile
+applets/Makefile
+applets/launcher/Makefile
])
dnl <= Configuration summary =>