summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorEric Fischer <eric@eazel.com>2001-03-12 20:56:56 +0000
committerEric Fischer <eric@src.gnome.org>2001-03-12 20:56:56 +0000
commitdf5dd7b83251ca6f04f031a7aea3d14434bfaa9d (patch)
tree642d792be723727fab5530666cb3159438592742 /configure.in
parent30d718c1d595eca56426d0627bbdde1b8954c5cf (diff)
downloadnautilus-df5dd7b83251ca6f04f031a7aea3d14434bfaa9d.tar.gz
Merge from 1.0 branch:
2001-03-12 Eric Fischer <eric@eazel.com> Merge from 1.0 branch: reviewed by: Robin * Slomkowski <rslomkow@eazel.com> * configure.in: Change ammonite version checking to use the same logic as other version number checks, to fix the broken tinderbox * nautilus.spec.in: Inherit the required ammonite version number from configure.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 6 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 2c3249b47..55ca737f8 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,7 @@ MEDUSA_REQUIRED=0.2.2
ESOUND_REQUIRED=0.2
LIBGHTTP_REQUIRED=1.0.9
SCROLLKEEPER_REQUIRED=0.1.4
+AMMONITE_REQUIRED=0.8.7
AC_SUBST(IMLIB_REQUIRED)
AC_SUBST(LIBXML_REQUIRED)
@@ -847,28 +848,12 @@ dnl = Begin tests for ammonite (--enable-eazel-services only)
dnl ====================================
if test "x$EAZEL_SERVICES_ENABLED" = "xyes" ;
then
- AC_MSG_CHECKING(for Ammonite >= 0.8.7)
- if test -n `gnome-config --libs ammonite | cut -d ' ' -f1`;
- then
- vers=`gnome-config --modversion ammonite | sed -e "s/[^-]*-//" | \
- awk 'BEGIN { FS = "."; } { printf "%d", $1 * 1000 + $2 * 100 + $3;}'`
- if test "$vers" -ge 807; then
- ammonite_ok=true;
- else
- ammonite_ok=false
- fi
- fi
+ EAZEL_VERSION_INSIST(ammonite, $GNOME_CONFIG --modversion ammonite | awk -F- '{print $2}', >=, AMMONITE_REQUIRED)
- if $ammonite_ok; then
- AMMONITE_CFLAGS=`gnome-config --cflags ammonite`
- AMMONITE_LIBS=`gnome-config --libs ammonite`
- AC_MSG_RESULT(yes)
- AC_SUBST(AMMONITE_CFLAGS)
- AC_SUBST(AMMONITE_LIBS)
- else
- AC_MSG_RESULT(no)
- AC_MSG_ERROR(Ammonite 0.8.7 or newer is required for Eazel Services. Please obtain it from Eazel's FTP site)
- fi
+ AMMONITE_CFLAGS=`$GNOME_CONFIG --cflags ammonite`
+ AMMONITE_LIBS=`$GNOME_CONFIG --libs ammonite`
+ AC_SUBST(AMMONITE_CFLAGS)
+ AC_SUBST(AMMONITE_LIBS)
fi
dnl =======================
dnl = End tests for ammonite