summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2003-10-14 16:00:32 +0000
committerAlexander Larsson <alexl@src.gnome.org>2003-10-14 16:00:32 +0000
commitf950720caa6d1ff3b805ab23a1267d0dcfd60282 (patch)
tree9cc2907667c53f86a1afb277509c010a191d97a9 /configure.in
parentb5fd55155ac4dea22949c5fd71525055166f4720 (diff)
downloadnautilus-f950720caa6d1ff3b805ab23a1267d0dcfd60282.tar.gz
Support for exif info.
2003-10-14 Alexander Larsson <alexl@redhat.com> * acconfig.h: * components/image_properties/Makefile.am: * components/image_properties/nautilus-image-properties-view.c: * configure.in: Support for exif info.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2b5c2f03e..f6d1ac430 100644
--- a/configure.in
+++ b/configure.in
@@ -20,6 +20,7 @@ MEDUSA_REQUIRED=0.5.1
RSVG_REQUIRED=2.0.1
XML_REQUIRED=2.4.7
STARTUP_NOTIFICATION_REQUIRED=0.5
+EXIF_REQUIRED=0.5.12
AC_SUBST(ART_REQUIRED)
AC_SUBST(BONOBO_ACTIVATION_REQUIRED)
@@ -223,6 +224,17 @@ if test "x$have_medusa" = "xyes"; then
EXTRA_CORE_MODULES="$EXTRA_CORE_MODULES medusa-2.0"
fi
+dnl exif checking
+
+AC_MSG_CHECKING(for libExif)
+
+PKG_CHECK_MODULES(EXIF, libexif >= $EXIF_REQUIRED, have_exif=yes, have_exif=no)
+if test "x$have_exif" = "xyes"; then
+ AC_DEFINE(HAVE_EXIF,1)
+ AC_SUBST(EXIF_CFLAGS)
+ AC_SUBST(EXIF_LIBS)
+fi
+
dnl ==========================================================================
dnl libjpeg