summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlex Graveley <alex@ximian.com>2002-05-22 21:34:19 +0000
committerAlex Graveley <orph@src.gnome.org>2002-05-22 21:34:19 +0000
commit93fd3d1018f5faafcacae67d08f6cb0197663203 (patch)
tree1c6190e78ff005b0329d4064fd4ee37c22a81b0d /configure.in
parentf25b7013cb8855a058abf40e7ea86472aed1a213 (diff)
downloadnautilus-93fd3d1018f5faafcacae67d08f6cb0197663203.tar.gz
Remove FAM check.
2002-05-22 Alex Graveley <alex@ximian.com> * configure.in: Remove FAM check. * acconfig.h: Remove HAVE_LIBFAM. * libnautilus-private/nautilus-monitor.[ch]: Convert to using gnome-vfs monitors. nautilus_monitor_active() now checks if FAM can be used by creating a monitor for the user's desktop directory, and caches this if successful. Adds an idle handler to call nautilus_file_changes_consume_changes(), so multiple file changes have a chance of being chunked together.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 1 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index a7d5406da..12076e29f 100644
--- a/configure.in
+++ b/configure.in
@@ -106,25 +106,6 @@ AC_CHECK_FUNCS(setenv unsetenv putenv)
dnl ==========================================================================
-dnl FAM
-
-AC_LANG_SAVE
-AC_LANG_CPLUSPLUS
-
-FAM_MISSING_WARNING="Nautilus depends on FAM to provide notification when files are altered (either through filesystem polling, or a kernel notification mechanism). If Nautilus is built without FAM support, directories viewed with Nautilus will not remain in synch with the actual filesystem when they are altered by external processes. Particularly if you are a distributor please compile Nautilus with FAM support. FAM is available from http://oss.sgi.com/projects/fam/. A patch to add Linux Kernel 2.4 directory notify support to FAM (highly desirable) is available from http://people.redhat.com/alexl/files/"
-FAM_LIBS=
-AC_CHECK_LIB(fam, FAMOpen,
- [AC_CHECK_HEADERS(fam.h,
- [AC_DEFINE(HAVE_LIBFAM)
- FAM_LIBS="-lfam"],
- AC_MSG_WARN(*** FAM support will not be built (header files not found) $FAM_MISSING_WARNING ***))],
- AC_MSG_WARN(*** FAM support will not be built (FAM library not found) $FAM_MISSING_WARNING ***))
-AC_SUBST(FAM_LIBS)
-
-AC_LANG_RESTORE
-
-dnl ==========================================================================
-
dnl x86 checks (used by audio routines in music component)
_system_is_x86="no"
@@ -287,7 +268,7 @@ dnl core nautilus (must list bonobo-activation and libbonobo because idldir does
CORE_MODULES="eel-2.0 librsvg-2.0 bonobo-activation-2.0 libbonobo-2.0 libbonoboui-2.0 esound gnome-desktop-2.0 $EXTRA_CORE_MODULES"
CORE_CFLAGS="`$PKG_CONFIG --cflags $CORE_MODULES` $x_cflags"
AC_SUBST(CORE_CFLAGS)
-CORE_LIBS="`$PKG_CONFIG --libs $CORE_MODULES` $CDDA_LIBS $FAM_LIBS $LIBJPEG $x_libs"
+CORE_LIBS="`$PKG_CONFIG --libs $CORE_MODULES` $CDDA_LIBS $LIBJPEG $x_libs"
AC_SUBST(CORE_LIBS)
CORE_IDL_INCLUDES="`$PKG_CONFIG --variable=idldir $CORE_MODULES | $srcdir/add-include-prefix`"
AC_SUBST(CORE_IDL_INCLUDES)