summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDarin Adler <darin@src.gnome.org>2001-12-07 02:47:06 +0000
committerDarin Adler <darin@src.gnome.org>2001-12-07 02:47:06 +0000
commit95b0620d8067835a4310aa207115e2470f65de1d (patch)
tree0a11e30fb739d843c1c5924357afaff5e7f292f1 /configure.in
parent529f8699bb173df350f50184b2cddb67c0ca9eff (diff)
downloadnautilus-95b0620d8067835a4310aa207115e2470f65de1d.tar.gz
Moved mozilla component into its own module.
* components/Makefile.am: * components/mozilla/.cvsignore: * components/mozilla/Makefile.am: * components/mozilla/Nautilus_View_mozilla.server.in: * components/mozilla/bonobo-extensions.c: * components/mozilla/bonobo-extensions.h: * components/mozilla/main.c: * components/mozilla/mozilla-components.cpp: * components/mozilla/mozilla-components.h: * components/mozilla/mozilla-events.cpp: * components/mozilla/mozilla-events.h: * components/mozilla/mozilla-preferences.cpp: * components/mozilla/mozilla-preferences.h: * components/mozilla/nautilus-mozilla-content-view.c: * components/mozilla/nautilus-mozilla-content-view.h: * components/mozilla/nautilus-mozilla-embed-extensions.cpp: * components/mozilla/nautilus-mozilla-embed-extensions.h: * components/mozilla/nautilus-mozilla-encoding-tables.c: * components/mozilla/nautilus-mozilla-encoding-tables.h: * components/mozilla/nautilus-mozilla-ui.xml: * configure.in: * nautilus.spec.in: Moved mozilla component into its own module.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in225
1 files changed, 0 insertions, 225 deletions
diff --git a/configure.in b/configure.in
index 8dd66db40..22ea40d69 100644
--- a/configure.in
+++ b/configure.in
@@ -173,190 +173,6 @@ AM_CONDITIONAL(X86_OPTIMIZED, test "x$_system_is_x86" = "xyes")
dnl ==========================================================================
-dnl ====================================
-dnl = mozilla embedded component support
-dnl =
-dnl = The following voodoo does detection of mozilla libraries needed by
-dnl = the nautilus mozilla component.
-dnl =
-dnl = The nautilus mozilla component is only built if these libraries are found
-dnl =
-dnl = --disable-mozilla-component can be used to disable building of the
-dnl = mozilla component even if the mozilla development libraries are
-dnl = detected.
-dnl ====================================
-
-mozilla_component_enabled="yes"
-
-AC_ARG_ENABLE(mozilla-component,
- [ --disable-mozilla-component Disable the mozilla component],
- mozilla_component_enabled="$enableval")
-
-dnl Dont build the mozilla component for profiled builds because the C++ compiler
-dnl used for mozilla rpms is not binary compatible with the one used for profiling.
-if test "x$ENABLE_PROFILER" = "x1"
-then
- mozilla_component_enabled="no"
-fi
-
-found_mozilla=false
-
-if test "x$mozilla_component_enabled" = "xyes"
-then
-
-_mozilla_lib_place=/usr/lib/mozilla
-AC_ARG_WITH(mozilla-lib-place,
- [ --with-mozilla-lib-place Set mozilla 'lib' place ],
- [ _mozilla_lib_place="$withval" ])
-
-_mozilla_include_place=/usr/include/mozilla
-AC_ARG_WITH(mozilla-include-place,
- [ --with-mozilla-include-place Set mozilla 'include' place ],
- [ _mozilla_include_place="$withval" ])
-
-_mozilla_nspr_include_place=$_mozilla_include_place/nspr
-AC_ARG_WITH(mozilla-nspr-include-place,
- [ --with-mozilla-nspr-include-place Set mozilla nspr directory 'include' place ],
- [ _mozilla_nspr_include_place="$withval" ])
-
-dnl Save flags and compiler
-_save_cflags="$CFLAGS"
-_save_ldflags="$LDFLAGS"
-_save_cc="$CC"
-
-dnl Hack flags to find the mozilla stuff
-CFLAGS="$_save_cflags -I$_mozilla_include_place -I$_mozilla_include_place/nspr"
-LDFLAGS="$_save_ldflags -L$_mozilla_lib_place"
-
-_mozilla_nspr_libs=
-AC_CHECK_LIB(nspr4, PR_Init, [_mozilla_nspr_libs="-lnspr4"])
-LDFLAGS="$LDFLAGS $_mozilla_nspr_libs"
-
-_mozilla_plc_libs=
-AC_CHECK_LIB(plc4, PL_strcmp, [_mozilla_plc_libs="-lplc4"])
-
-_mozilla_plds_libs=
-AC_CHECK_LIB(plds4, PL_NewHashTable, [_mozilla_plds_libs="-lplds4"])
-
-_mozilla_all_nspr_flags="$_mozilla_nspr_libs $_mozilla_plc_libs $_mozilla_plds_libs"
-
-dnl Now check for the evil c++ ones "by hand"
-CC="g++"
-
-LDFLAGS="$_save_ldflags -L$_mozilla_lib_place $_mozilla_all_nspr_flags -lxpcom"
-AC_MSG_CHECKING(for xpcom)
-AC_CACHE_VAL(have_xpcom,
- [AC_TRY_COMPILE([extern "C" int NS_RegistryGetFactory(void**);]
- [],
- [NS_RegistryGetFactory(0); return 0;],
- [have_xpcom=true],
- [have_xpcom=false])])
-if test "$have_xpcom" = "true" ; then
- _mozilla_xpcom_libs="-lxpcom"
- AC_MSG_RESULT(yes)
-else
- _mozilla_xpcom_libs=
- AC_MSG_RESULT(no)
-fi
-
-dnl The next two are pure evil
-CC="$_save_cc"
-
-dnl gtk superwin library
-LDFLAGS="$_save_ldflags -L$_mozilla_lib_place $_mozilla_all_nspr_flags -lgtksuperwin"
-_mozilla_gtk_super_win_libs=
-AC_CHECK_LIB(gtksuperwin, gdk_superwin_get_type, [_mozilla_gtk_super_win_libs="-lgtksuperwin"])
-
-dnl gtk moz embed library
-LDFLAGS="$_save_ldflags -L$_mozilla_lib_place $_mozilla_all_nspr_flags -lgtkembedmoz $_mozilla_xpcom_libs"
-_mozilla_gtk_moz_embed_libs=
-AC_CHECK_LIB(gtkembedmoz, gtk_moz_embed_get_type, [_mozilla_gtk_moz_embed_libs="-lgtkembedmoz"])
-
-dnl Restore the flags and compiler
-CFLAGS="$_save_cflags"
-LDFLAGS="$_save_ldflags"
-CC="$_save_cc"
-
-dnl Now make sure all the libraries are good
-AC_MSG_CHECKING(for Mozilla)
-
-if test -n "$_mozilla_nspr_libs" -a \
- -n "$_mozilla_plc_libs" -a \
- -n "$_mozilla_plds_libs" -a \
- -n "$_mozilla_xpcom_libs" -a \
- -n "$_mozilla_gtk_super_win_libs" -a \
- -n "$_mozilla_gtk_moz_embed_libs"
-then
- AC_MSG_RESULT(yes)
- AC_PROG_CXX
- found_mozilla=true
-
- MOZILLA_COMPONENT_RPATH_FLAGS=-Wl,-rpath=$_mozilla_lib_place
- MOZILLA_COMPONENT_LDFLAGS=-L$_mozilla_lib_place
- MOZILLA_COMPONENT_LIBS="$_mozilla_gtk_moz_embed_libs \
- $_mozilla_gtk_super_win_libs \
- $_mozilla_xpcom_libs \
- $_mozilla_nspr_libs \
- $_mozilla_plc_libs \
- $_mozilla_plds_libs"
- AC_SUBST(MOZILLA_COMPONENT_RPATH_FLAGS)
- AC_SUBST(MOZILLA_COMPONENT_LDFLAGS)
- AC_SUBST(MOZILLA_COMPONENT_LIBS)
-else
- AC_MSG_RESULT(no)
- found_mozilla=false
-fi
-
-fi
-
-AM_CONDITIONAL(BUILD_MOZILLA_COMPONENT, test "$found_mozilla" = "true")
-
-if test "$found_mozilla" = "true"
-then
- grep -w gtk_moz_embed_set_profile_path $_mozilla_include_place/gtkembedmoz/gtkmozembed.h > /dev/null 2>&1
- if test $? -eq 0
- then
- MOZILLA_PROFILES_CFLAGS="-DMOZILLA_HAVE_PROFILES_SUPPORT"
- AC_SUBST(MOZILLA_PROFILES_CFLAGS)
-
- MOZILLA_COMPONENT_CFLAGS="-I$_mozilla_include_place -I$_mozilla_nspr_include_place -fno-rtti -fno-exceptions"
- for component in xpcom gfx widget gtkembedmoz dom \
- webbrwsr docshell content layout pref uconv string; do
- MOZILLA_COMPONENT_CFLAGS="$MOZILLA_COMPONENT_CFLAGS -I$_mozilla_include_place/$component"
- done
- AC_SUBST(MOZILLA_COMPONENT_CFLAGS)
- else
- AC_MSG_ERROR([
-*** Mozilla 0.9.5 or greater is required to build the
-*** Nautilus Mozilla component.])
- fi
-
-dnl The DEBUG check is a most evil hack. The problem im trying to solve
-dnl is that we dont know whether the mozilla binaries we are using are built
-dnl in debug mode or not (DEBUG). We need to know this so that we set
-dnl appropiate compile flags in the mozilla component. Otherwise we get
-dnl undefined symbols. Specifically, the undefined symbols are some
-dnl destrcutors (nsCOMPtr_base::~nsCOMPtr_base) which are implemented only
-dnl if the debug flag DEBUG is set a certain way.
-
- _xpcom_lib=$_mozilla_lib_place/libxpcom.so
- _symbol="nsCOMPtr_base::~nsCOMPtr_base"
- _num_symbols=`nm $_xpcom_lib 2> /dev/null | wc -l`
-
- MOZILLA_COMPONENT_DEBUG_FLAGS=
- if test $_num_symbols -ne 0
- then
- nm --demangle $_xpcom_lib | grep $_symbol > /dev/null 2>&1
- if test $? -eq 1
- then
- MOZILLA_COMPONENT_DEBUG_FLAGS="-DDEBUG"
- fi
- fi
- AC_SUBST(MOZILLA_COMPONENT_DEBUG_FLAGS)
-fi
-
-dnl ==========================================================================
-
dnl cdda
AM_CONDITIONAL(HAVE_CDDA, false);
@@ -552,7 +368,6 @@ components/image-viewer/Makefile
components/loser/Makefile
components/loser/content/Makefile
components/loser/sidebar/Makefile
-components/mozilla/Makefile
components/music/Makefile
components/news/Makefile
components/notes/Makefile
@@ -614,43 +429,3 @@ user-guide/gnugpl/Makefile
])
dnl ==========================================================================
-
-dnl <= Configuration summary =>
-
-echo "Nautilus configuration summary:"
-echo ""
-
-dnl <= CFLAGS and LDFLAGS =>
-
-echo "CFLAGS : $CFLAGS"
-echo "LDFLAGS : $LDFLAGS"
-echo ""
-
-dnl <= Mozilla component integrated? =>
-
-case $found_mozilla in
- t*)
- echo "Mozilla component : YES"
- echo " mozilla libraries : $_mozilla_lib_place"
- echo " mozilla includes : $_mozilla_include_place"
- echo " MOZILLA_PROFILES_CFLAGS : $MOZILLA_PROFILES_CFLAGS"
- echo " MOZILLA_COMPONENT_RPATH_FLAGS : $MOZILLA_COMPONENT_RPATH_FLAGS"
- echo " MOZILLA_COMPONENT_DEBUG_FLAGS : $MOZILLA_COMPONENT_DEBUG_FLAGS"
- ;;
- *)
- echo "Mozilla component : NO"
- ;;
-esac
-
-dnl <= Profile support? =>
-
-case "X$ENABLE_PROFILER" in
- X1)
- echo "Enable profiler : YES"
- ;;
- *)
- echo "Enable profiler : NO"
- ;;
-esac
-
-dnl <= End of configuration summary =>