summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2006-07-25 14:18:03 +0000
committerAlexander Larsson <alexl@src.gnome.org>2006-07-25 14:18:03 +0000
commit15e1a7fc2b9125a14fa996f27cb337af18bf158b (patch)
treeb6c0c971c59196c25fbe9a456528244fa85aae5b /configure.in
parentc7a0a93b37614cff567a525bad1e22df853d7a3d (diff)
downloadnautilus-15e1a7fc2b9125a14fa996f27cb337af18bf158b.tar.gz
Translate the selinux context from raw form when displayin.
2006-07-25 Alexander Larsson <alexl@redhat.com> * libnautilus-private/nautilus-file.c (nautilus_file_get_selinux_context): Translate the selinux context from raw form when displayin.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e81ee0915..8ee025df6 100644
--- a/configure.in
+++ b/configure.in
@@ -269,6 +269,25 @@ fi
dnl ==========================================================================
+dnl ****************************
+dnl *** Check for libselinux ***
+dnl ****************************
+
+SELINUX_LIBS=
+msg_selinux=no
+AC_CHECK_LIB(selinux, is_selinux_enabled,
+ [AC_CHECK_HEADERS(selinux/selinux.h,
+ [AC_SEARCH_LIBS(selinux_raw_to_trans_context, selinux,
+ [AC_DEFINE(HAVE_SELINUX, 1, [Define to 1 if libselinux is available])
+ SELINUX_LIBS="-lselinux"
+ msg_selinux=yes])
+ ])
+ ])
+AC_SUBST(SELINUX_LIBS)
+
+
+dnl ==========================================================================
+
dnl Turn on the additional warnings last, so -Werror doesn't affect other tests.
AC_ARG_ENABLE(more-warnings,