summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlex Duggan <aldug@gnome.org>2003-01-09 18:44:10 +0000
committerAlex Duggan <aldug@src.gnome.org>2003-01-09 18:44:10 +0000
commita8ef1c04f40c6a81ecf92475f2aff7e3ca34ef98 (patch)
treeb54e5eb467e1cbe2150b4a8d691ca99373c91f91 /configure.in
parent9d0c2f37b19a97ed9b2e6ada4dfbc652bee0de30 (diff)
downloadnautilus-a8ef1c04f40c6a81ecf92475f2aff7e3ca34ef98.tar.gz
Use pkg-config instead of orbit2-config. (fixes #73299)
2003-01-08 Alex Duggan <aldug@gnome.org> * configure.in: Use pkg-config instead of orbit2-config. (fixes #73299) * libnautilus-private/nautilus-icon-container.c: Remove unneccessary include of libnautilus/nautilus-clipboard.h * src/file-manager/fm-directory-view.c: Remove unnecessary include of fm-desktop-icon-view.h Patch from David Bordoley <bordoley@msu.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 94c4e448b..80802b444 100644
--- a/configure.in
+++ b/configure.in
@@ -13,6 +13,7 @@ GNOME_DESKTOP_REQUIRED=2.1.0
GNOME_REQUIRED=2.1.1
GNOME_UI_REQUIRED=2.1.1
GNOME_VFS_REQUIRED=2.1.5
+ORBIT_REQUIRED=2.4.0
PANGO_REQUIRED=1.1.2
GTK_REQUIRED=2.1.1
MEDUSA_REQUIRED=0.5.1
@@ -44,8 +45,6 @@ AC_PROG_MAKE_SET
AM_DISABLE_STATIC
AM_PROG_LIBTOOL
-AM_PATH_ORBIT2
-
PKG_CHECK_MODULES(ALL, \
esound >= $ESOUND_REQUIRED \
bonobo-activation-2.0 >= $BONOBO_ACTIVATION_REQUIRED \
@@ -53,6 +52,7 @@ PKG_CHECK_MODULES(ALL, \
glib-2.0 >= $GLIB_REQUIRED \
gnome-desktop-2.0 >= $GNOME_DESKTOP_REQUIRED \
gnome-vfs-2.0 >= $GNOME_VFS_REQUIRED \
+ ORBit-2.0 >= $ORBIT_REQUIRED\
pango >= $PANGO_REQUIRED \
gtk+-2.0 >= $GTK_REQUIRED \
libart-2.0 >= $ART_REQUIRED \
@@ -99,6 +99,11 @@ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
dnl ==========================================================================
+ORBIT_IDL="`$PKG_CONFIG --variable=orbit_idl ORBit-2.0`"
+AC_SUBST(ORBIT_IDL)
+
+dnl ==========================================================================
+
AC_CHECK_FUNCS(setmntent endmntent hasmntopt getmntinfo)
AC_CHECK_HEADERS(mntent.h sys/mnttab.h sys/vfstab.h sys/cdio.h sys/mount.h)