summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorElliot Lee <sopwith@src.gnome.org>2000-11-10 01:58:43 +0000
committerElliot Lee <sopwith@src.gnome.org>2000-11-10 01:58:43 +0000
commit5868f1bf7ac560a63d2cec5053da85eb832aa954 (patch)
tree1efea2714c56637f5350130c9d58f5a4090f68c8 /configure.in
parent5122c9f427c7dc6cb6a31fe5af61deaa0cb12a0d (diff)
downloadnautilus-5868f1bf7ac560a63d2cec5053da85eb832aa954.tar.gz
Fix freetype2 detection fix srcdir != builddir.
* configure.in: Fix freetype2 detection * Various makefiles: fix srcdir != builddir.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 19 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 146afb102..e4f72d429 100644
--- a/configure.in
+++ b/configure.in
@@ -95,22 +95,33 @@ _found_freetype2_lib="no"
_found_freetype2_header="no"
_found_freetype2="no"
-AC_ARG_WITH(freetype2,
-[ --with-freetype2-lib-prefix=PREFIX freetype2 library path],
-freetype2_lib_prefix=$withval,
-freetype2_lib_prefix="/usr/lib")
+AC_ARG_WITH(freetype2-libraries,
+[ --with-freetype2-libraries=PATH freetype2 library path],
+freetype2_lib_prefix=$withval)
-AC_ARG_WITH(freetype2,
-[ --with-freetype2-include-prefix=PREFIX freetype2 include path],
-freetype2_include_prefix=$withval,
-freetype2_include_prefix="/usr/include/freetype2")
+AC_ARG_WITH(freetype2-includes,
+[ --with-freetype2-includes=PATH freetype2 include path],
+freetype2_include_prefix=$withval)
+AC_ARG_WITH(freetype2-prefix,
+[ --with-freetype2-prefix=PATH freetype2 installation prefix],
+freetype2_prefix=$withval, freetype2_prefix="/usr")
+
+if test -z "$freetype2_include_prefix"; then
+ freetype2_include_prefix="${freetype2_prefix}/include/freetype2"
+fi
+if test -z "$freetype2_lib_prefix"; then
+ freetype2_lib_prefix="${freetype2_prefix}/lib"
+fi
_save_cpp="$CPP"
+_save_ldflags="$LDFLAGS"
CPP="$_save_cpp -I$freetype2_include_prefix"
+LDFLAGS="$_save_ldflags -L$freetype2_lib_prefix"
AC_CHECK_HEADER(freetype/freetype.h, _found_freetype2_header="yes")
AC_CHECK_LIB(freetype, FT_Init_FreeType, [_found_freetype2_lib="yes"])
CPP="$_save_cpp"
+LDFLAGS="$_save_ldflags"
if test "x$_found_freetype2_lib" = "xyes" -a \
"x$_found_freetype2_header" = "xyes"