summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRamiro Estrugo <ramiro@src.gnome.org>2000-04-19 10:05:14 +0000
committerRamiro Estrugo <ramiro@src.gnome.org>2000-04-19 10:05:14 +0000
commitcf496b8e0a24d60e1f770c396394bd41b0188645 (patch)
tree02dc4698dcdb4841555ce93c56196003cad1f1f1 /configure.in
parentfef6546735105a7fbb9c58bcd381f12fa6394f80 (diff)
downloadnautilus-cf496b8e0a24d60e1f770c396394bd41b0188645.tar.gz
Add voodoo to support --with-mozilla.
* configure.in: Add voodoo to support --with-mozilla. * components/Makefile.am: Add conditional build of mozilla subdir. * components/mozilla/Makefile.am: Un-hardcode cflags and libs. Use the values set in configure instead.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in67
1 files changed, 67 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e3cc24346..9008e1950 100644
--- a/configure.in
+++ b/configure.in
@@ -50,6 +50,73 @@ AC_SUBST(EAZEL_SERVICES)
AM_CONDITIONAL(EAZEL_SERVICES, test "x$EAZEL_SERVICES" = "x1")
+dnl ====================================
+dnl =
+dnl = mozilla embedded component support
+dnl =
+dnl ====================================
+BUILD_MOZILLA_COMPONENT=
+
+try_mozilla="false"
+mozilla_place=
+
+AC_MSG_CHECKING(for Mozilla)
+
+AC_ARG_WITH(mozilla,
+ [--{with,without}-mozilla Compile with Mozilla embedded component support or without it],
+ if test "$withval" = "no"; then
+ try_mozilla="false"
+ else
+ try_mozilla="true"
+ mozilla_place=$withval
+ fi
+)
+
+dnl FIXME: there obviously needs to be a better test that checking for libxpcom.so
+if test "$try_mozilla" = "true"
+then
+ found_mozilla="false"
+
+ if test -d $mozilla_place/dist/bin
+ then
+ if test -x $mozilla_place/dist/bin/libxpcom.so
+ then
+ found_mozilla="true"
+ fi
+ fi
+
+ if test "$found_mozilla" = "true"
+ then
+ AC_MSG_RESULT(yes)
+
+ echo " Using Mozilla installation in $mozilla_place"
+
+ MOZILLA_COMPONENT_CFLAGS=-I${mozilla_place}/dist/include
+ MOZILLA_COMPONENT_LDFLAGS=-L${mozilla_place}/dist/bin
+ MOZILLA_COMPONENT_LIBS="-lgtkembedmoz -lgtksuperwin -lxpcom -lnspr4 -lplc4 -lplds4"
+
+ AC_SUBST(MOZILLA_COMPONENT_CFLAGS)
+ AC_SUBST(MOZILLA_COMPONENT_LDFLAGS)
+ AC_SUBST(MOZILLA_COMPONENT_LIBS)
+ else
+ AC_MSG_RESULT(no)
+AC_MSG_ERROR(
+***
+*** There doesnt seem to be a valid mozilla installation in $mozilla_place.
+*** Please fetch the latest mozilla milestone from
+*** ftp://ftp.mozilla.org/pub/mozilla/releases/.
+***)
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+
+AM_CONDITIONAL(BUILD_MOZILLA_COMPONENT, test "x$found_mozilla" = "xtrue")
+
+dnl ====================================
+dnl = end mozilla hacks
+dnl ====================================
+
dnl Checks for libraries.
AM_PATH_GLIB(1.2.0,,
AC_MSG_ERROR([