summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2010-05-20 14:34:00 +0200
committerCosimo Cecchi <cosimoc@gnome.org>2010-05-20 14:34:00 +0200
commit86d41c14159741c6803940a83a42e40a89d061d7 (patch)
tree96274bd38e79ce98bdbb90eb5d29dee252af4c12 /configure.in
parent2617e16aa55367ba3d73a33dc27376cf518d4676 (diff)
downloadnautilus-86d41c14159741c6803940a83a42e40a89d061d7.tar.gz
Split WARNING_CFLAGS into its own variable.
So that we can use e.g. LIBNAUTILUS_EXTENSIONS_CFLAGS when compiling the gir information.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0004678e3..2a9873d1e 100644
--- a/configure.in
+++ b/configure.in
@@ -237,6 +237,8 @@ dnl ==========================================================================
dnl Turn on the additional warnings last, so -Werror doesn't affect other tests.
+WARNING_CFLAGS=""
+
AC_ARG_ENABLE(more-warnings,
AC_HELP_STRING([--enable-more-warnings], [Maximum compiler warnings]),
set_more_warnings="$enableval",[
@@ -277,6 +279,8 @@ else
AC_MSG_RESULT(no)
fi
+AC_SUBST(WARNING_CFLAGS)
+
dnl ===========================================================================
dnl strftime checks
@@ -327,14 +331,14 @@ AC_SUBST(LIBEGG_LIBS)
dnl libnautilus-extension
LIBNAUTILUS_EXTENSION_MODULES="glib-2.0 gtk+-2.0"
-LIBNAUTILUS_EXTENSION_CFLAGS="`$PKG_CONFIG --cflags $LIBNAUTILUS_EXTENSION_MODULES` $WARNING_CFLAGS"
+LIBNAUTILUS_EXTENSION_CFLAGS="`$PKG_CONFIG --cflags $LIBNAUTILUS_EXTENSION_MODULES`"
AC_SUBST(LIBNAUTILUS_EXTENSION_CFLAGS)
LIBNAUTILUS_EXTENSION_LIBS="`$PKG_CONFIG --libs $LIBNAUTILUS_EXTENSION_MODULES`"
AC_SUBST(LIBNAUTILUS_EXTENSION_LIBS)
dnl core nautilus
CORE_MODULES="glib-2.0 gnome-desktop-2.0 gthread-2.0 gio-2.0 gio-unix-2.0 unique-1.0 dbus-glib-1 gail gconf-2.0 libxml-2.0 $EXTRA_CORE_MODULES"
-CORE_CFLAGS="`$PKG_CONFIG --cflags $CORE_MODULES` $x_cflags $WARNING_CFLAGS"
+CORE_CFLAGS="`$PKG_CONFIG --cflags $CORE_MODULES` $x_cflags"
AC_SUBST(CORE_CFLAGS)
CORE_LIBS="`$PKG_CONFIG --libs $CORE_MODULES` $x_libs"
AC_SUBST(CORE_LIBS)