summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2010-10-29 18:15:47 +0100
committerBastien Nocera <hadess@hadess.net>2010-11-01 13:17:49 +0000
commitb4aa3c083ab7616f321df4ade75e4d850142eff6 (patch)
tree92e62be3fce2cee2c9be6d90b55210d4068873b8 /configure.in
parent0609431a5cb3803d0b98bd333f90e3c7796f86b7 (diff)
downloadnautilus-b4aa3c083ab7616f321df4ade75e4d850142eff6.tar.gz
Move nautilus-sendto extension to nautilus
And add a check for the presence of nautilus-sendto to the initialisation of the object. Building the extension is optional, though on by default. https://bugzilla.gnome.org/show_bug.cgi?id=633485
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 01c5dfb03..4d8febbc2 100644
--- a/configure.in
+++ b/configure.in
@@ -90,6 +90,18 @@ dnl ==========================================================================
AC_CHECK_PROGS(PERL, perl5 perl)
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+
+dnl ==========================================================================
+dnl Check whether to build the nautilus-sendto extension
+
+AC_ARG_ENABLE(nst_extension,
+ AC_HELP_STRING([--disable-nst-extension],
+ [build without nautilus-sendto extension]))
+if test "x$enable_nst_extension" != "xno"; then
+ AM_CONDITIONAL(ENABLE_NST_EXTENSION, true)
+ enable_nst_extension=yes
+fi
+
dnl ==========================================================================
AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/param.h malloc.h)
@@ -371,6 +383,7 @@ libnautilus-extension/libnautilus-extension-uninstalled.pc
po/Makefile.in
src/Makefile
src/file-manager/Makefile
+nautilus-sendto-extension/Makefile
test/Makefile
])
@@ -386,6 +399,7 @@ nautilus-$VERSION:
libexif support: $msg_libexif
libexempi support: $msg_xmp
PackageKit support: $msg_packagekit
+ nautilus-sendto ext: $enable_nst_extension
profiling support: ${profiling_support}
nautilus-extension documentation: ${enable_gtk_doc}