summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorElliot Lee <sopwith@src.gnome.org>1999-12-15 19:07:14 +0000
committerElliot Lee <sopwith@src.gnome.org>1999-12-15 19:07:14 +0000
commit8c729d0d1089b479434b30b72f4041cf86dbfe7b (patch)
tree5c8eb4eab7ca8a4b0688c6c8c3fd6ce8bf7a4533 /configure.in
parente66ad3393afb9414f63acb18a4bf222079c967b8 (diff)
downloadnautilus-8c729d0d1089b479434b30b72f4041cf86dbfe7b.tar.gz
Add --enable-more-warnings and --enable-fatal-warnings switches. Add
* configure.in: Add --enable-more-warnings and --enable-fatal-warnings switches. * src/ntl-uri-map.c: Add comment about functionality-in-waiting.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 17 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index ed5c8f8c7..2d879f0eb 100644
--- a/configure.in
+++ b/configure.in
@@ -43,19 +43,23 @@ dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
dnl Some additional warning options.
-CFLAGS="$CFLAGS \
--W \
--Wcast-align \
--Wchar-subscripts \
--Werror \
--Wmissing-declarations \
--Wmissing-prototypes \
--Wnested-externs \
--Wpointer-arith \
--Wno-sign-compare \
--Wsign-promo \
--trigraphs \
-"
+AC_ARG_ENABLE(more-warnings, [--enable-more-warnings Maximum compiler warnings],
+ enable_compile_warnings="$enableval", enable_compile_warnings=yes)
+AC_ARG_ENABLE(fatal-warnings, [--enable-fatal-warnings Make warnings fatal],
+ enable_fatal_warnings="$enableval", enable_fatal_warnings=yes)
+
+# Arg is enabled
+if test "$GCC" = "yes" && test "$enable_compile_warnings" != "no"; then
+ CFLAGS="$CFLAGS \
+ -W -Wcast-align -Wchar-subscripts \
+ -Wmissing-declarations -Wmissing-prototypes \
+ -Wnested-externs -Wpointer-arith \
+ -Wno-sign-compare -Wsign-promo -Wshadow \
+ -Wpadded -Wundef"
+fi
+if test "$GCC" = "yes" && test "$enable_fatal_warnings" != "no"; then
+ CFLAGS="$CFLAGS -Werror"
+fi
AC_OUTPUT([
Makefile