summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2011-05-24 14:43:23 -0400
committerCosimo Cecchi <cosimoc@gnome.org>2011-05-24 14:46:10 -0400
commitfc3d9af1dff85ef27ff44ea4e71b269a2b700e7d (patch)
tree4edd70fe07f73e8a59e5d19828b0c13da1e6994b /data/Makefile.am
parent636c06bdc3397b1c6bad78afe2094c149c59f6fb (diff)
downloadnautilus-fc3d9af1dff85ef27ff44ea4e71b269a2b700e7d.tar.gz
autostart: add an autostart desktop file
It will autostart nautilus automatically based on the GSettings key org.gnome.desktop.background show-desktop-icons. https://bugzilla.gnome.org/show_bug.cgi?id=647267
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index aa76c1655..19eddcd57 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -9,6 +9,11 @@ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
desktop_in_files = \
nautilus.desktop.in \
nautilus-autorun-software.desktop.in
+
+autostartdir = $(sysconfdir)/xdg/autostart
+autostart_in_files = nautilus-autostart.desktop.in
+autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+
@INTLTOOL_DESKTOP_RULE@
mimedir = $(datadir)/mime/packages
@@ -37,11 +42,13 @@ EXTRA_DIST = $(nautilusdata_DATA) \
$(xml_in_files) \
$(desktop_in_files) \
$(service_in_files) \
+ $(autostart_in_files) \
$(NULL)
CLEANFILES = $(xml_files) \
$(desktop_DATA) \
$(service_DATA) \
+ $(autostart_DATA) \
$(NULL)
SUBDIRS = \