summaryrefslogtreecommitdiff
path: root/libnautilus-private/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2000-08-22 04:35:04 +0000
committerGeorge Lebl <jirka@src.gnome.org>2000-08-22 04:35:04 +0000
commitdc605a304ced48d2eb52efeabeaf138f763af276 (patch)
treece470dd29bbc133c1bb1f7c5691db9ab7bddc80d /libnautilus-private/Makefile.am
parent7295589544bf5b28024f25ab5783e0f8ec273502 (diff)
downloadnautilus-dc605a304ced48d2eb52efeabeaf138f763af276.tar.gz
properly handle gconf error, and init it to NULL first. This will avoid
Mon Aug 21 23:35:18 2000 George Lebl <jirka@5z.com> * components/html/ntl-web-browser.c (main): properly handle gconf error, and init it to NULL first. This will avoid crashes on error. * libnautilus-extentions/Makefile.am, libnautilus-extentions/nautilus-preferences-private.h, libnautilus-extentions/nautilus-preferences.c: Add a nautilus_preferences_handle_error functions for use in nautilus-preferences and user level manager to handle and reset GConf exceptions. The reason a new "private" header was added is to preserve the gconf encapsulation outside libnautilus-extentions, plus it's only useful there. * libnautilus-extentions/nautilus-preferences.c (preferences_hash_node_add_callback) (preferences_hash_node_remove_callback) (preferences_gconf_callback) (preferences_initialize_if_needed) (nautilus_preferences_set_boolean) (nautilus_preferences_get_boolean) (nautilus_preferences_set_string_list) (nautilus_preferences_get_string_list) (nautilus_preferences_set_enum) (nautilus_preferences_get_enum) (nautilus_preferences_set) (nautilus_preferences_get) libnautilus-extensions/nautilus-user-level-manager.c (user_level_manager_new) (user_level_manager_ensure_global_manager) (nautilus_user_level_manager_set_user_level) (nautilus_user_level_manager_get_user_level_as_string) (nautilus_user_level_manager_set_default_value_if_needed) (nautilus_user_level_manager_compare_preference_between_user_levels): Handle GConf exceptions. Try to revert to sane behaviour on errors, such as using defaults. Remove all the asserts for conditions that arise from gconf errors. Fixes bug 672
Diffstat (limited to 'libnautilus-private/Makefile.am')
-rw-r--r--libnautilus-private/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libnautilus-private/Makefile.am b/libnautilus-private/Makefile.am
index 6316fb8cb..6ac0c82ea 100644
--- a/libnautilus-private/Makefile.am
+++ b/libnautilus-private/Makefile.am
@@ -184,6 +184,7 @@ noinst_HEADERS = \
nautilus-preferences-item.h \
nautilus-preferences-pane.h \
nautilus-preferences.h \
+ nautilus-preferences-private.h \
nautilus-program-chooser.h \
nautilus-program-choosing.h \
nautilus-radio-button-group.h \