summaryrefslogtreecommitdiff
path: root/libnautilus-private/Makefile.am
diff options
context:
space:
mode:
authorRamiro Estrugo <ramiro@src.gnome.org>2001-03-31 16:06:47 +0000
committerRamiro Estrugo <ramiro@src.gnome.org>2001-03-31 16:06:47 +0000
commit50644c182db0a7dea20ab076f7b10659967a79ae (patch)
treebb857bc4df5a6f8e1d82c040fccecfbe23ed71d9 /libnautilus-private/Makefile.am
parentbb8afb01b90e0e0d363248c713409d6ddda8fb7a (diff)
downloadnautilus-50644c182db0a7dea20ab076f7b10659967a79ae.tar.gz
New functions. Move sidebar and sidebar panel specific code used
* libnautilus-extensions/Makefile.am: * libnautilus-extensions/nautilus-sidebar-functions.h: * libnautilus-extensions/nautilus-sidebar-functions.c: (compare_view_identifiers), (sidebar_is_sidebar_panel_enabled), (sidebar_is_sidebar_panel_enabled_cover), (sidebar_get_sidebar_panel_view_identifiers), (nautilus_sidebar_get_enabled_sidebar_panel_view_identifiers), (nautilus_sidebar_panel_make_preference_key), (nautilus_sidebar_for_each_panel): New functions. Move sidebar and sidebar panel specific code used throughout Nautilus to its own place. * libnautilus-extensions/nautilus-global-preferences.c: (global_preferences_populate_sidebar_panels_callback), (global_preferences_create_sidebar_panels_pane), (global_preferences_install_sidebar_panel_defaults): Move sidebar and sidebar panel specific code to nautilus-sidebar-functions.[ch]. Simplify sidebar panel creation a bit. * libnautilus-extensions/nautilus-global-preferences.h: Remove the sidebar panel NAMESPACE as preferences dont support namespaces any more. * src/nautilus-sidebar.c: (any_panel_matches_iid): Tiny anal renaming. (toggle_sidebar_panel): Simplify this function a bit. The previous "dance" that the code was doing was not really necessariy. (sidebar_for_each_sidebar_panel), (sidebar_add_panel_context_menu_items): Simplify a lot by using the new sidebar panel iterator. Remove a bunch of oaf code which is handled by the iterator in sidebar-functions. Also, only create the menu items if the preference is visible at the current user level. (nautilus_sidebar_get_sidebar_panel_key): Yank this function as it is not needed anymore. * src/nautilus-window.c: (nautilus_window_for_each_sidebar_panel), (nautilus_window_initialize): Keep track of sidebar panel changes for each individual panel instead of trying to use the whole namespace. The namespace thing was a broken feature of preferences which is no longer supported. (update_sidebar_panels_from_preferences): Update for new public sidebar functions.
Diffstat (limited to 'libnautilus-private/Makefile.am')
-rw-r--r--libnautilus-private/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libnautilus-private/Makefile.am b/libnautilus-private/Makefile.am
index a2abf7838..30bb99b77 100644
--- a/libnautilus-private/Makefile.am
+++ b/libnautilus-private/Makefile.am
@@ -147,8 +147,9 @@ libnautilus_extensions_la_SOURCES = \
nautilus-scalable-font.c \
nautilus-search-uri.c \
nautilus-self-checks.c \
- nautilus-smooth-text-layout.c \
+ nautilus-sidebar-functions.c \
nautilus-smooth-text-layout-cache.c \
+ nautilus-smooth-text-layout.c \
nautilus-smooth-widget.c \
nautilus-sound.c \
nautilus-stock-dialogs.c \
@@ -273,8 +274,9 @@ noinst_HEADERS = \
nautilus-scalable-font.h \
nautilus-search-uri.h \
nautilus-self-checks.h \
- nautilus-smooth-text-layout.h \
+ nautilus-sidebar-functions.h \
nautilus-smooth-text-layout-cache.h \
+ nautilus-smooth-text-layout.h \
nautilus-smooth-widget.h \
nautilus-sound.h \
nautilus-stock-dialogs.h \