summaryrefslogtreecommitdiff
path: root/libnautilus-private/Makefile.am
diff options
context:
space:
mode:
authorDarin Adler <darin@src.gnome.org>2000-11-09 01:36:13 +0000
committerDarin Adler <darin@src.gnome.org>2000-11-09 01:36:13 +0000
commita03bb1a3166bc03f33bbd2d4f61cfb44c3a4692b (patch)
treefbb19fd6789c3d267167ff7f2a23a1f413e2fb1b /libnautilus-private/Makefile.am
parent40eb73da3962485ccd9aadf85639088e26d64c5a (diff)
downloadnautilus-a03bb1a3166bc03f33bbd2d4f61cfb44c3a4692b.tar.gz
buddy: Gene Ragan <gzr@eazel.com>
* libnautilus-extensions/nautilus-file.c: (rename_callback): Since metadata for the directory itself is now stored under a fixed name, no need to rename the metadata for self-owned files any more. (get_item_count), (get_size), (compare_directories_by_count), (compare_files_by_size), (compare_by_size): Reimplement compares by size so they don't use gnome_vfs_file_info_compare -- this makes them work better for info == NULL cases. (get_date), (compare_by_modification_date): Reimplement compares by modification date so they don't use gnome_vfs_file_info_compare -- this makes them work better for info == NULL cases. (compare_by_name): Sort files that start with "." or "#" last. (compare_by_name_and_directory_name): Helper function so that we always sort by directory name when names are equal. (nautilus_file_compare_for_sort): Use the new functions above so we never have to use the gnome_vfs_file_info_compare function. Because of that, we won't have to keep file names around any more. This also simplified the logic -- I was able to remove all the special cases for info == NULL. (get_metadata_name): Function that returns "." for self-owned files so the metadata for the directory itself is stored somewhere that's not affected by renaming. (nautilus_file_get_metadata), (nautilus_file_get_metadata_list), (nautilus_file_set_metadata), (nautilus_file_set_metadata_list), (nautilus_file_get_boolean_metadata), (nautilus_file_get_integer_metadata), (nautilus_file_set_boolean_metadata), (nautilus_file_set_integer_metadata): Use the new get_metadata_name function. * src/file-manager/nautilus-directory-view-ui.xml: Changed an old <menuitem/> to <separator/>. * po/.cvsignore: Ignore the tmp directory, but no need to ignore the .headerlock file which is now obsolete. * README: Minor tweaks. * libnautilus-extensions/Makefile.am: Resorted lists.
Diffstat (limited to 'libnautilus-private/Makefile.am')
-rw-r--r--libnautilus-private/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/libnautilus-private/Makefile.am b/libnautilus-private/Makefile.am
index 6bc7bb0bb..80a434818 100644
--- a/libnautilus-private/Makefile.am
+++ b/libnautilus-private/Makefile.am
@@ -44,8 +44,6 @@ libnautilus_extensions_la_LDFLAGS = \
$(NULL)
libnautilus_extensions_la_SOURCES = \
- nautilus-file-operations-progress.c \
- nautilus-file-operations.c \
nautilus-background-canvas-group.c \
nautilus-background.c \
nautilus-bonobo-extensions.c \
@@ -63,10 +61,12 @@ libnautilus_extensions_la_SOURCES = \
nautilus-directory-metafile.c \
nautilus-directory.c \
nautilus-drag.c \
- nautilus-druid.c \
nautilus-druid-page-eazel.c \
+ nautilus-druid.c \
nautilus-entry.c \
nautilus-file-changes-queue.c \
+ nautilus-file-operations-progress.c \
+ nautilus-file-operations.c \
nautilus-file-utilities.c \
nautilus-file.c \
nautilus-font-factory.c \
@@ -132,8 +132,6 @@ libnautilus_extensions_la_SOURCES = \
# Everything is private for now
noinst_HEADERS = \
- nautilus-file-operations.h \
- nautilus-file-operations-progress.h \
nautilus-background-canvas-group.h \
nautilus-background.h \
nautilus-bonobo-extensions.h \
@@ -153,11 +151,13 @@ noinst_HEADERS = \
nautilus-directory-private.h \
nautilus-directory.h \
nautilus-drag.h \
- nautilus-druid.h \
nautilus-druid-page-eazel.h \
+ nautilus-druid.h \
nautilus-entry.h \
nautilus-file-attributes.h \
nautilus-file-changes-queue.h \
+ nautilus-file-operations-progress.h \
+ nautilus-file-operations.h \
nautilus-file-private.h \
nautilus-file-utilities.h \
nautilus-file.h \
@@ -176,8 +176,8 @@ noinst_HEADERS = \
nautilus-icon-canvas-item.h \
nautilus-icon-container.h \
nautilus-icon-dnd.h \
- nautilus-icon-factory.h \
nautilus-icon-factory-private.h \
+ nautilus-icon-factory.h \
nautilus-icon-private.h \
nautilus-icon-text-item.h \
nautilus-image.h \
@@ -199,8 +199,8 @@ noinst_HEADERS = \
nautilus-preferences-group.h \
nautilus-preferences-item.h \
nautilus-preferences-pane.h \
- nautilus-preferences.h \
nautilus-preferences-private.h \
+ nautilus-preferences.h \
nautilus-program-chooser.h \
nautilus-program-choosing.h \
nautilus-radio-button-group.h \