summaryrefslogtreecommitdiff
path: root/libnautilus/Makefile.am
diff options
context:
space:
mode:
authorDarin Adler <darin@src.gnome.org>2000-10-20 19:09:34 +0000
committerDarin Adler <darin@src.gnome.org>2000-10-20 19:09:34 +0000
commit06005f269a1038ec63ce43081c0f9461800932f3 (patch)
tree361a69873d1efe7ec5f6acc1286b4015314e40cb /libnautilus/Makefile.am
parent61b85f7dd422e83a61f1149c2c9e668cfe9085d4 (diff)
downloadnautilus-06005f269a1038ec63ce43081c0f9461800932f3.tar.gz
Moved some shared Makefile stuff to a shared include file so we don't use
* Makefile.am: * Makefile.shared: * components/loser/content/Makefile.am: * components/loser/sidebar/Makefile.am: * components/mozilla/Makefile.am: * components/sample/Makefile.am: * components/services/install/command-line/Makefile.am: * components/services/summary/nautilus-view/Makefile.am: * libnautilus-extensions/Makefile.am: * libnautilus/Makefile.am: * src/Makefile.am: * src/file-manager/Makefile.am: Moved some shared Makefile stuff to a shared include file so we don't use "copy and paste technology" in our Makefiles. Fixed the rule that builds .xml.h files so it doesn't have to be copied and pasted everywhere. * components/loser/content/nautilus-content-loser-ui.xml.h: * components/loser/sidebar/nautilus-sidebar-loser-ui.xml.h: * components/mozilla/nautilus-mozilla-ui.xml.h: * components/sample/nautilus-sample-content-view-ui.xml.h: * libnautilus/nautilus-clipboard-ui.xml.h: * src/file-manager/nautilus-directory-view-ui.xml.h: * src/file-manager/nautilus-icon-view-ui.xml.h: * src/file-manager/nautilus-search-list-view-ui.xml.h: * src/nautilus-shell-ui.xml.h: Regenerated the xml.h files with the new Bonobo tool, which keeps things in alphabetical order to minimize cvs thrashing. * components/services/summary/nautilus-view/Makefile.am: * components/services/summary/nautilus-view/nautilus-summary-view-ui.xml.h: Added localization for the summary view UI. * src/Makefile.am: Added localization for the service UI pieces. * libnautilus-extensions/nautilus-buffered-widget.c: (nautilus_buffered_widget_initialize), (connect_to_background_if_needed): Fixed bug where the widget would stay connected after the background was destroyed. John saw it once, but I'm not sure how to reproduce it. * nautilus.spec.in: Fix some bad spelling and strange wording. * src/nautilus-applicable-views.h: * src/nautilus-applicable-views.c: (got_file_info_callback), (nautilus_navigation_info_new), (nautilus_navigation_info_cancel), (nautilus_navigation_info_free), (nautilus_navigation_info_get_location), (nautilus_navigation_info_get_initial_content_id): Removed lots of cruft from this class so it's private and can be changed around a bit. * src/nautilus-window-manage-views.c: (nautilus_window_update_internals): Use the new nautilus_navigation_info_get_location. (handle_unreadable_location): Get rid of unneeded file == NULL check. (load_view_for_new_location): Use the new nautilus_navigation_info_get_initial_content_id. (set_view_location_and_selection): Use the new nautilus_navigation_info_get_location. (nautilus_window_end_location_change_callback): Use the new nautilus_navigation_info_get_location. (nautilus_window_begin_location_change): Remove some unnecessary code.
Diffstat (limited to 'libnautilus/Makefile.am')
-rw-r--r--libnautilus/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/libnautilus/Makefile.am b/libnautilus/Makefile.am
index 955e4df43..89cb4ad63 100644
--- a/libnautilus/Makefile.am
+++ b/libnautilus/Makefile.am
@@ -1,4 +1,4 @@
-NULL=
+include $(top_srcdir)/Makefile.shared
lib_LTLIBRARIES=libnautilus.la
@@ -75,19 +75,14 @@ uidir = $(datadir)/gnome/ui
ui_DATA = \
nautilus-clipboard-ui.xml \
$(NULL)
-
ui_msgs = \
- nautilus-clipboard-ui.xml.h
-
-nautilus-clipboard-ui.xml.h: $(srcdir)/nautilus-clipboard-ui.xml
- $(BONOBO_UI_EXTRACT) $(srcdir)/nautilus-clipboard-ui.xml > \
- nautilus-clipboard-ui.xml.h
+ nautilus-clipboard-ui.xml.h \
+ $(NULL)
EXTRA_DIST = \
$(ui_DATA) \
nautilus-view-component.idl \
nautilus-distributed-undo.idl \
- $(ui_msgs) \
$(NULL)
BUILT_SOURCES = \
@@ -103,4 +98,3 @@ CLEANFILES = \
nautilus_distributed_undo_idl_stamp \
$(ui_msgs) \
$(NULL)
-