summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Soriano <csoriano@gnome.org>2017-02-27 16:03:05 +0100
committerCarlos Soriano <csoriano@gnome.org>2017-02-27 16:06:11 +0100
commit12826378e12d4f42a8ea01ef0594838f1dbd9225 (patch)
treea1598253ae14e3cfd38f53a79e837d8643a7d347 /meson.build
parentec92b8ab602e910e906014cdaca88e92e4ac84e7 (diff)
downloadnautilus-12826378e12d4f42a8ea01ef0594838f1dbd9225.tar.gz
meson: ignore deprecations warnings
We know we have deprecations functions, and they require a major work as porting to gtk4. That's truly a different task to what we are doing every day, and the multiple warnings obscure all real warnings to the task that is relevant at that point. This is making contributors skip the warnings, rather than actually look at them. For that, ignore deprecation warnings for now until someone wants to work in the gtk4 port, and we also assume you read the documentation when introducing new code in order to avoid deprecations.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e99061356..25910c7d6 100644
--- a/meson.build
+++ b/meson.build
@@ -3,6 +3,8 @@ project ('nautilus', 'c',
meson_version: '>=0.37.0',
license: 'GPL2+')
+add_global_arguments ('-Wno-deprecated-declarations', language:'c')
+
bindir = get_option ('bindir')
datadir = get_option ('datadir')
appdatadir = join_paths (datadir, 'appdata')