summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2018-01-04 17:27:13 +0200
committerErnestas Kulik <ernestask@gnome.org>2018-01-04 17:35:51 +0200
commit01352d3b2263d0d173d8546e92781e6662336e64 (patch)
tree94a5f215a0a257c462a4641b3db80580545c96ed /meson.build
parent70ac3742d65e6bb15c3819176252e79da207eda5 (diff)
downloadnautilus-01352d3b2263d0d173d8546e92781e6662336e64.tar.gz
build: drop use of disabler object
Should have read docs more carefully. An empty array does the trick just as well, with the side effect of not breaking builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 876915e68..cf450e2a1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('nautilus', 'c',
version: '3.27.2',
- meson_version: '>= 0.44.0',
+ meson_version: '>= 0.41.0',
license: 'GPL3+'
)
@@ -51,7 +51,7 @@ gmodule = dependency('gmodule-no-export-2.0', version: glib_ver)
gnome_autoar = dependency('gnome-autoar-0', version: '>= 0.2.1')
gnome_desktop = dependency('gnome-desktop-3.0', version: '>= 3.0.0')
gtk = dependency('gtk+-3.0', version: '>= 3.22.26')
-selinux = disabler()
+selinux = []
if get_option('selinux')
selinux = dependency('libselinux', version: '>= 2.0')
endif