summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2018-01-30 20:30:10 +0200
committerErnestas Kulik <ernestask@gnome.org>2018-02-09 06:32:38 +0200
commit2128efccae664ba12a870deb1720a08e58954dd2 (patch)
tree5bbd644700dcb6ab3408398891e2293001c173ec /meson.build
parent432f15dec785c51d9e9580450856ed4caec8ea6f (diff)
downloadnautilus-2128efccae664ba12a870deb1720a08e58954dd2.tar.gz
nautilus-extension: use Meson to generate pkgconfig file
Currently, the pkgconfig file for nautilus-extension is generated by substituting variables in a template file. That is prone to mistakes and requires manual tracking of dependencies. Using the pkgconfig module from Meson helps automate much of the process.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 290b302fa..33b37dc9c 100644
--- a/meson.build
+++ b/meson.build
@@ -24,6 +24,7 @@ cc = meson.get_compiler('c')
# Imports
gnome = import('gnome')
i18n = import('i18n')
+pkgconfig = import('pkgconfig')
#
# Dependencies