summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2018-10-08 14:15:39 +0300
committerErnestas Kulik <ernestask@gnome.org>2018-10-09 11:01:37 +0300
commit942429b13389c1db1c370e87f971a2c368056f33 (patch)
tree8f6a7acf02526e577fc950444234d96933c2b2e1 /meson.build
parente97155f1d1f6c6711de84492135723ac9b83b2c3 (diff)
downloadnautilus-942429b13389c1db1c370e87f971a2c368056f33.tar.gz
meson.build: Use set instead of set10
Since we only care about whether those macros are defined, we can use set to save a few lines.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 3 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index ecadf01f5..6e5add1b2 100644
--- a/meson.build
+++ b/meson.build
@@ -177,15 +177,9 @@ conf.set_quoted('VERSION', '@0@-@VCS_TAG@'.format(meson.project_version()))
conf.set('ENABLE_SECCOMP', seccomp.found())
conf.set('HAVE_BWRAP', seccomp.found())
-if get_option('packagekit')
- conf.set10('ENABLE_PACKAGEKIT', true)
-endif
-if get_option('profiling')
- conf.set10('ENABLE_PROFILING', true)
-endif
-if get_option('selinux')
- conf.set10('HAVE_SELINUX', true)
-endif
+conf.set('ENABLE_PACKAGEKIT', get_option('packagekit'))
+conf.set('ENABLE_PROFILING', get_option('profiling'))
+conf.set('HAVE_SELINUX', get_option('selinux'))
#############################################################
# config.h dependency, add to target dependencies if needed #