summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAntónio Fernandes <antoniof@gnome.org>2017-11-29 17:36:08 +0000
committerAntónio Fernandes <antoniof@gnome.org>2017-11-29 17:36:08 +0000
commit2c5882aaffd88ebd4bc477c8d94a3e56d2fcb2fb (patch)
treecc65c8e16f69065c2974cc0220def902c85143a8 /meson.build
parent1962dd81f7619ad2d3dad8c5ec6df6fe02a4492a (diff)
downloadnautilus-2c5882aaffd88ebd4bc477c8d94a3e56d2fcb2fb.tar.gz
build: Detect X11/XF86keysym.h to enable extra keys
Support for special keyboard keys for actions such as Back, Forward, Refresh, Go Home, etc. depends on this header. We used to check for this header in configure.ac but this was lost when porting from autotools to meson (commit 857a90c2). Restore this support by checking for this header with meson. Fixes #134
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 79702078e..060e8026e 100644
--- a/meson.build
+++ b/meson.build
@@ -81,6 +81,10 @@ if not tracker_sparql.found()
tracker_sparql = dependency ('tracker-sparql-1.0')
endif
+if cc.has_header ('X11/XF86keysym.h')
+ conf.set10 ('HAVE_X11_XF86KEYSYM_H', true)
+endif
+
configure_file (input: 'config.h.meson',
output: 'config.h',
configuration: conf)