summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2017-03-05 21:49:17 +0200
committerErnestas Kulik <ernestask@gnome.org>2017-03-06 17:43:22 +0200
commitdc57c21448157c696bbe1315d2b7d7e5d3b9a180 (patch)
tree12d31b398b54331fddb52cd067c109f158c90e64 /meson.build
parentf80af5094c1d342c56d21e29942221f6836e3cd0 (diff)
downloadnautilus-dc57c21448157c696bbe1315d2b7d7e5d3b9a180.tar.gz
meson: update submodule only if it doesn’t exist
Some build servers don’t have git installed, which makes the tarball build fail when trying to update the libgd submodule. This commit adds a check for the existence of the root meson.build of libgd before running git. https://bugzilla.gnome.org/show_bug.cgi?id=779603
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8a6d65914..13a92f69a 100644
--- a/meson.build
+++ b/meson.build
@@ -102,8 +102,8 @@ nautilus_include_dirs = include_directories ('.')
subdir ('eel')
subdir ('libnautilus-extension')
-message ('Updating libgd submodule…')
-run_command ('git', '--git-dir="$MESON_SOURCE_ROOT/.git"', 'submodule', 'update', '--init', 'libgd')
+message ('Checking for libgd…')
+run_command ('check_libgd.sh')
libgd_options = ['static=true',
'with-gtk-hacks=true',