summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlexandru Fazakas <alex.fazakas97@yahoo.com>2018-02-21 00:14:45 +0200
committerAlexandru Fazakas <alex.fazakas97@yahoo.com>2018-02-27 07:06:57 +0200
commit5da4acab69b5b5ae63eb409b52d624e4f56d17e8 (patch)
tree3211936e7fdbd4f45e23434098534e7a8728ca10 /meson.build
parent7e7eac3a95ac81594a2d0e0e975cc78b167c62b5 (diff)
downloadnautilus-5da4acab69b5b5ae63eb409b52d624e4f56d17e8.tar.gz
files-view: Avoid leaking selection list and data
Sometimes, while working with the files_view_get_selection function, the freeing is not done properly. We leak a lot of objects as of this and we need a way to fix it. To avoid leaking, we implemented g_autoptr support for NautilusFile in order to have at our disposal automatic, deep cleanup whenever we use the function. In this patch, we changed all calls to use g_autolist appropriately and bumped the glib dependency up to 2.55.1 (in order for us to use g_autolist). Fixes https://gitlab.gnome.org/GNOME/nautilus/issues/226
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3b5c8dbff..1c6976797 100644
--- a/meson.build
+++ b/meson.build
@@ -28,7 +28,7 @@ pkgconfig = import('pkgconfig')
#
# Dependencies
-glib_ver = '>= 2.51.2'
+glib_ver = '>= 2.55.1'
libgd = subproject(
'libgd',